Graphics card not recognized

I am using a new Dell Latitude E6500.
Video Card is an NVIDIA Quadro NVS 160M
I believe it is a 256MB card.

I just installed my first drivers with ndiswrapper to get the system to recognize my wireless chip. Am I going to have to do something similar for this situation?

Basically, the system boots up with an odd resolution. It looks very late 90’s. YaST > Hardware > Graphics Card and Monitor reveals:

Card: VESA Framebuffer Graphics

Monitor: i set this personally to 1440 x 900 because thats what my actual monitor is. it was set to something lower initially. changing this setting earned me an error message about how something wasn’t supported.

the resolution defaults to 800x600 SVGA with 16-bit color.

Also, the option to enable 3-D acceleration is greyed out.

Have a read of this thread;
Yet another Nvidia question - openSUSE Forums


I followed the tutorial up to this point…


YaST -> Software -> Software Repositories -> Add

Protocol: HTTP
Server Name: :
Directory on Server: /opensuse/11.0

to add the NVIDIA http server as additional installation source.
Now use

YaST -> Software -> Software Management

to install the NVIDIA driver. The appropriate NVIDIA packages will be
autoselected, if your card is supported. These are either

a) x11-video-nvidia + nvidia-gfx-kmp-(kernel_flavor)


b) x11-video-nvidiaG01 + nvidia-gfxG01-kmp-(kernel_flavor)

If no additional packages are autoselected, your card is not supported
by the driver (RPMs) at the moment.

Nothing was autoselected.

I skipped this first part…

Update your Kernel via YOU (YaST Online Update).

I spent a very long time getting my system to recognize my wireless card. I tried updating the kernel at first, didnt work. then i realized a ton of stuff was wrong with my installation, so i reinstalled openSUSE. i was told not to update the kernel this time. it is all documented in the first 3 pages here…

New to Linux - can’t get my wireless to work - openSUSE Forums

I would recommend you follow the “Hard Way” as I’m not sure if the drivers there are up to date.

Run through those three zypper commands to update your system first.


Well to follow the easy way, your kernel needs to match what’s in the

For the hardway you need to download the kernel-source and
syms to match your current kernel. Sort of a catch 22 situation.

What is the output from;

uname -a

Cheers Malcolm °¿° (Linux Counter #276890)
SLED 10.0 SP2 x86_64 Kernel
up 6 days 4:51, 2 users, load average: 0.28, 0.48, 0.52
GPU GeForce 8600 GTS Silent - Driver Version: 177.80

linux-34ss:/home/music # sudo zypper ref
Repository ‘Updates for 11.0’ is up to date.
Repository ‘openSUSE-11.0-Non-Oss’ is up to date.
Repository ‘openSUSE-11.0-Oss’ is up to date.
Repository ‘11.0’ is up to date.
All repositories have been refreshed.

linux-34ss:/home/music # sudo zypper lu
Reading installed packages…

Warning: These are only the updates affecting the updater itself.
Other updates are available too.

Repository | Name | Version | Category | Status
Updates for 11.0 | PackageKit | 139 | recommended | Needed
Updates for 11.0 | libzypp | 53 | recommended | Needed
Updates for 11.0 | yast2-ncurses-pkg | 83 | recommended | Needed
Updates for 11.0 | zypper | 114 | recommended | Needed

the third zypper command returned a huge amount of output. here’s a synopsis…

linux-34ss:/home/music # sudo zypper up
Reading installed packages…

The following packages are going to be upgraded:
satsolver-tools libzypp yast2-pkg-bindings zypper yast2-ncurses-pkg

The following NEW patches are going to be installed:
PackageKit zypper yast2-ncurses-pkg libzypp

Overall download size: 3.0 M. After the operation, additional 21.0 K will be used.
Continue? [YES/no]: yes

Installing: yast2-ncurses-pkg-2.16.14-0.2 [done]
Warning: One of installed patches affects the package manager itself, thus it requires its restart before executing any further operations.

i dont know what that means, so i’m going to restart my computer. brb.

linux-34ss:/home/music # uname -a
Linux linux-34ss #1 SMP 2008-06-07 01:55:22 +0200 i686 i686 i386 GNU/Linux

When you run those commands again, you should get a lot of updates
including the kernel which by the sounds of it you don’t want to
update? Else do you need to run through all the commands you did last
time to get the wireless to work?

Cheers Malcolm °¿° (Linux Counter #276890)
SLED 10.0 SP2 x86_64 Kernel
up 6 days 5:27, 1 user, load average: 0.22, 0.10, 0.09
GPU GeForce 8600 GTS Silent - Driver Version: 177.80

If you don’t have the kernel source and tools etc installed then

sudo zypper in kernel-source linux-kernel-headers kernel-syms
sudo zypper in -t pattern devel_basis devel_C_C++

is this what i need to do now? or did i just get this stuff when i ran zypper up?

i’m not sure i understand. i need to run the three zypper commands again? i have no problem with updating the kernel, as long as it won’t mess up the wireless driver that i used ndiswrapper to install.

Yes, that is the default kernel at install, there have been a few since
then up to now.

So can the commands you ran for the wireless be done again for a later

Cheers Malcolm °¿° (Linux Counter #276890)
SLED 10.0 SP2 x86_64 Kernel
up 6 days 5:36, 1 user, load average: 0.02, 0.06, 0.08
GPU GeForce 8600 GTS Silent - Driver Version: 177.80

: (

not yet. i spent the last three weeks getting my wireless to work. just got it going a few hours ago. i need a break. lol.

If you disable the update repository via YaST then update the
kernel-source etc it will pull it from the DVD (unless you installed
from the liveCD?).

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 0:08, 1 user, load average: 0.00, 0.44, 0.37
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

ok, i guess a have a couple questions though (very new to linux). when i first installed openSUSE 11, as part of a dual-boot with vista, neither my wireless or my graphics card were properly recognized. i heard tons of rumors that all i needed to do was update the kernel to 2.6.27, so i did. and it was a ton of work, and it didnt help my wireless or graphics card. in fact, it shutdown my LAN.

i ended up reinstalling from DVD (had used liveCD originally), and instead, solved the wireless issue by using ndiswrapper.


  1. why cant i use ndiswrapper to fix my graphics card as well?
  2. why would updating the kernel undo my work fixing my wireless?


  1. ndiswrapper is that a ndis wrapper around/using the windows sys and
    inf files to activate your wirelss and nothing to do with graphics :slight_smile:

  2. There is however an ndiswrapper kernel module. If you use YaST and
    the software management, search on ndis and you will see a
    ndiswrapper-kmp-(your kernel type) is installed. Update the kernel and
    that will get updated too :slight_smile:

I see there are also a couple of GUI tools you can use to install as
well, but I digress…

I would imagine it should just work, but you never know :frowning: I would
wait a day, as it looks like there is a new kernel out so it will need
to propagate to the mirrors, unless you see it

Cheers Malcolm °¿° (Linux Counter #276890)
SLED 10.0 SP2 x86_64 Kernel
up 6 days 19:51, 1 user, load average: 0.13, 0.53, 0.50
GPU GeForce 8600 GTS Silent - Driver Version: 177.80

i will get right back to work on this tomorrow. i just needed a small break from my driver dilemna.