Graphical Yast Does Not work After Upgrade from Leap 15.3 to 15.4

Hi Everyone.

I have recently upgraded from Leap 15.3 to Leap 15.4.

The graphical interface of Yast no longer seems to work.

That is, it asks for the password when clicked upon. I enter the password, but the interface does not load as expected. Any ideas?

Thanks You!

@KittyKatty Hi, have you seen this thread related to the same type of issue? No yast apps starting

Thank you @malcolmlewis !

I checked the thread and tried the ruby package fixes:

zypper in -f ruby2.5-stdlib


zypper in --no-recommends -f $(rpm -qa  ruby* --qf '%{NAME} ') 

And tried changing the kernel version to 5.14.21-150400.24.46.1

However, no luck so far. Any suggestions?

@KittyKatty not sure if the kernel is an issue, suggest you run the latest 5.14.21-150400.24.55.

If you open a teminal and switch to root user su - and then run yast2 how is that?

Thank you again!

I get Yast2 running in the text mode:

@KittyKatty that’s yast the ncurses version, did you try the command yast2

Thank you for your continued help!

To be sure, I did ran yast2 (no typo) and still the ncurses version comes up.

I did find though it does give this error first:

$ /usr/sbin/yast2 
Qt GUI wanted but not found, falling back to ncurses.

@KittyKatty you need to be root user to run YaST2.

Did you try to read error message?

You need package yast2-control-center-qt.

Thank you so much!

sudo zypper in yast2-control-center-qt

Solved it for me!

I really appreciate all of your help!

Hello, it happened to me that by having the log files in ram editing the fstab file, the directory /root/var/log/YaST2 is deleted
As a consequence, Yast does not start the modules in graphical mode.
I have created a script: “var_log_YaST2” that is executed at boot so that it creates that directory and Yast finds it and solves the problem

sudo mkdir /var/log/YaST2

Ready !
Maybe it can be of help to someone