Graphical User Interface won't load on startup


I’ve installed Opensuse for the third time because the last two times it failed to load the graphical user interface on startup. I tried in safe mode and didn’t
work either. It started on 12.3 but then happened on 13.1 also. I read on a forum thread from an earlier version of opensuse that sometimes Opensuse
has problems with ATI video cards on high resolution. I run opensuse on a Toshiba Satellite laptop with an ATI Radeon 3200 video card. I lowered the
resolution a notch in the hope that it prevents the same problem happening again.

Anyone got any clue as to what my problem might be and how to prevent it happening again?

Did you install the propritary ATI driver?

Can you boot to terminal mode?

You can use yast to install the ATI driver from there

Note as a general rule reinstalling does not fix things.

The proprietary ATI driver does not support an ATI Radeon 3200 video card (only HD5000 and up).
And the legacy driver which would support it does not work on openSUSE since 12.3 because XOrg is too new.

So, please don’t try to install that.

Also, if it doesn’t even work in safe mode, it shouldn’t really be a graphics driver problem.

So is it working now?

What do you mean with “high resolution”? I never had a problem with 1280x1024 (my monitor’s native resolution) on my old Radeon 9600…

IIUYC it did work and suddenly stopped working, right? And then you only got into text mode?
Was there any update involved?

Hard to say why it failed without a log file. If it does happen again, login to text mode and save away /var/log/Xorg.0.log, that should provide a clue why X doesn’t start up.

It stopped working after a few weeks on both occasions. There were many updates preceding the failure so if that was the cause
it would be hard to identify exactly which update it was. Anyway, when it happened the computer was running but just with a blank screen
so I rebooted. When it came back it only got as far as the splash screen but wouldn’t load my home GUI settings. When I said safe mode it was
incorrect. What I actually did was reboot again and tried to launch from GRUB using the second option (Secure mode). This displayed a lot of text but on each occasions it halted trying to load the Graphical User Interface and would go no further. I couldn’t get to a command prompt either to try and do something from there.

The screen resolution options are:

1366 X 768
1280 X 720
1052 X 768
etc …

It was set to the first option but I’ve now dropped it down to the third option (1052 X 768).

It’s working fine now but that was the case also the two times before, it worked for a few weeks but then exactly the same problem occurred
on both occasions, it just fell over suddenly. I don’t want to wait for it to happen again, I’m looking to take preventative measures this time. :expressionless:

Sorry, I chose ‘openSUSE 13.1, with Linux 3.11.6-4-desktop (recovery mode)’ from the Advanced menu option to try and bring back my setting, not secure mode.