Graphical session refusing to start after installing fglrx.

So I attempted to install AMD graphic driver yesterday. Upon reboot, my computer was instead starting on terminal.
tried starting X manually but receive this message:

All packages are properly installed
(zypper in fglrx64*)

my system spec:
openSUSE 13.2
Intel I7-4770K
Vapor-X Sapphire R9-270X
Asus Maximus Ranger

have to revert back to radeon driver.
Anyone can explain the message and help me to solve this?

The message is irrelevant.

But currently GDM doesn’t work at all with fglrx, it just crashes. There are other threads about this as well, and it is being investigated.

The only workaround I am aware of, is to use a different displaymanager (GNOME itself should work fine).
xdm is installed by default, available in the standard repos are lightdm, lxdm, sddm, wdm, and kdm.

Install one of them and set DISPLAYMANAGER in /etc/sysconfig/displaymanager accordingly. Or set it to “xdm”, which is rather basic though (it’s Xorg’s own fallback DM).

Im using the default GNOME,
so which display manager is recommended?

Well, I would recommend kdm… :wink:

But seriously, this would probably pull in half of KDE which might not be very preferable for you.

I would suggest to try xdm first, to see if it works. If not, you have a different problem, and another one would not help either.

And I would probably suggest lightdm for GNOME, as that is quite lightweight (as the name suggests) and comes with a GTK greeter (a Qt one is available as well though).

SDDM is nice as well, but quite young and still missing features. It uses Qt5 as toolkit, which you should have installed anyway as YaST Qt also uses it. (on 13.2 YaST’s Qt version should be installed by default even on GNOME, because the GTK version has severe problems and even got dropped completely recently)

lxdm is the displaymanager for lxde, so probably quite lightweight as well.
I don’t know much about it though, or the others.

Ah. it working now. Thanks.

Using lightdm now.

tried to install sddm but it pull like 450mb of dependencies. Im not going to like that lol.
trying to keep my system free from unnecessary clutter.

Well, sddm itself is quite small and light.

But as mentioned it uses Qt5, which you may not have installed already on a GNOME system (unless you use YaST Qt, which is the default).

But sddm-openSUSE-branding uses the breeze theme, which requires parts of KDE Plasma5 (sddm is actually the new displaymanager for “KDE5”).
Installing sddm-branding-upstream instead would probably have been better and the other themes are also nice…

Should have mentioned that, but I didn’t think of it.

Anyway, I guess you’re fine with lightdm either… :wink: