Graphical problem after update failure

Last session, I ran Zypper updates, which failed because I was out of space on /root– I really need to watch out for that. I don’t remember what the updates were, but Nvidia was among them. Today openSUSE booted to command line, and startx failed. It did not give me one of those ‘EE’ error messages.

I’m guessing I need to undo the failed updates. Like is there a way to see what packages they were and downgrade them? Or should I just force-reinstall some graphics-related packages, and if so, how do I figure out which? I have hybrid Intel and Nvidia.

That can’t be true. You probably mean /.


I’ve now freed up space on the physical drive where it is mounted. The internet tells me Apt keeps a log of recent updates, but I can’t find anything like that for Zypper. Should I just reinstall every package with Nvidia or Intel in the name, or something?

When you ran out of space whilst an zypper up, why do you believe that the graphics driver is the culprit? Having no space on / whilst update may leave your system in a broken and unpredictable state because different dependencies may be broken now.

Roll back to a working snapshot.
Free up space on /.
Rerun zypper up

Unfortunately I don’t use Btfrs. I might simply reinstall.

You could try if a zypper up helps.

It is in “/var/log/zypp/history”.

Well, that was easier than I thought. Zypper update worked. Thought the graphics must’ve been badly broken by failing in the middle of the update.
Thanks, and sorry for the dumb question.

1 Like

Nice you repaired it. Enjoy openSUSE.

Much easier read of zypp history file for all days from system install is in:

yast → software management → extras → history

tom kosvic