Graphical login lost after distribution upgrade from 11.2 to 11.3

I attempted to perform an in-place distribution upgrade from openSUSE 11.2 to openSUSE 11.3 following the instructions (zypper dup). The upgrade appeared to succeed, but after I rebooted I was presented with a console login. It seems that I lost the graphical login.

How do I restore the graphical login?

As both 11.2 and 11.3 are out of support, I am not sure if many people can recreate what you did. In any case the repos for 11.3 you used must be from some place that offers this for the few who want to stick to an old version and not any more from the openSUSE download site itself.

Why don’t you go for 12.2 with a fresh install, while keeping your /home parttition (if you have one, else by backup andrestore of it)?

OTOH, you could wait for some general solutions to your problem, but those are also to be found on the forums here with the search function I guess.

I appreciate your input Henk.

Since I am running openSUSE in vmWare, there was a problem with the proprietary drivers. I reinstalled vmWare Tools and everything’s working now.

Good you found a solution :wink:

But consider upgrading to a supported kevel. There comes a time when you got stuck. And that will allways be on the moment you can not afford it.

If you do not want to go for 12.1 or 12.2 you could do one additional
upgrade to 11.4 and then in November add the Evergreen repositories for
long term support (11.4 will be supported)
http://en.opensuse.org/openSUSE:Evergreen


PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10