Graphical glitches with compositing and 3D rendering on Intel IGP


I’ve been running Leap for a while now with my current laptop. It features an i3-5005U processor with Intel HD Graphics 5500. It used to run absolutely flawlessly until about 3 days ago when I started to notice weird white dots, lines and shapes scrambling my screen when the desktop rendering effects were running, when 3D was being rendered or when video was displayed.

I tried to switch from modesetting to intel drivers without success.

I don’t think it is a hardware issue though, at least I don’t want it to be one.

What could I do to find out the problem and resolve it ?
What infos could be useful for this purpose ?

Thanks in advance


Can you, by any chance, confirm that the graphics are okay until the first sleep/wake-up cycle (closing the lid, then opening it again after a while? Or is it glitchy right from the first cold boot?

Not that I could offer any further advice, but I’ve had similar glitches with my desktop system and its Core-i5 on-chip GPU following each standby/system-wake. (I eventually installed a cheap PCI-E gfx card and the problem was gone — a solution probably not applicable to your system.)

Was 3 days ago before kernel-default-4.12.14-lp150.12.45.1 was installed? Has it been installed? For many it was expected to and did produce fixes for various graphical problems.

For your GPU the modesetting driver is probably expected to do a better job than xf86-video-intel, which hasn’t had an official release in nearly 4 years. Intel’s driver writers have been focusing on the modesetting driver at least that long.

Unfortunately the glitchyness extravanagza starts right from cold boot…

What’s also worth mentionning is that I have had way worse graphical issues on Windows with any version of the Intel drivers right from when I updated to Win10. With standard (unaccelerated) VGA generic drivers there’s no issue whatsoever.

However I’ve had accelerated graphics working flawlessly on Linux with modesetting drivers since I bought the PC 2 years ago until wednesday or so.

It started before I installed this kernel update.
Actually I installed it just earlier today and nothing’s changed…

FYI I reverted back to modesetting driver today too. Still no change though.

Do you still have 12.22 or 12.25 kernels to try in your Grub menu?