Graphical corruption on fresh install of 11.2 on Novatech (Clevo) M670SU

Hi guys,

I recently decided to give OpenSUSE a go on my new Clevo laptop. I’ve run the installer, and installed everything (I want to use all its features, I’m into programming and stuff!).

The install went fine, it’s when I rebooted the problem started. It does all the stuff it needs to, then gets to starting HAL.

The screen then goes off, and comes back all corrupt. The machine then seems to crash, as the Caps Lock light doesn’t respond, and my CPU fan kicks in to full. Rebooting causes the same.

My hardware is:

Intel Core 2 Duo T5600 1.83GHz



VIA VN896 chipset

nVidia Geforce Go 8400M G graphics with 128MB RAM

Sony NEC Optiarc 8x DVD-+RW DL burner

I’ve read from BillyDoc that it tries to use a 1600x1200 resolution, and my GPU does a max of 1440x900, but Safe Mode and Failsafe do the same to me, I can’t figure out how to get it to use a lower res, so I can determine if it’s a driver or res issue.

I’m using GNOME desktop, using KDE does the same. Thanks in advance for any help. I’ve used OpenSUSE before on both desktops and laptops, and love it, just never had such a problem on a laptop install!

I’ll pass a link of some practical graphic theory, in case this might be graphic related.
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

per that above guide, can you boot to runlevel 3 , then login as a regular user, then type “su” and enter root password.

Then check, does your PC have an /etc/X11/xorg.conf file? If so, delete it. Then reboot with “shutdown -r now”. Do you still have this problem?

If so (or if your PC does NOT have an /etc/X11/xorg.conf file) try using the installation xorg configuration file as a temporary work around by this:

cp /etc/X11/xorg.conf.install /etc/X11/xorg.conf

and then reboot with “shutdown -r now”. Do you still have this problem?

Thanks oldcpu, I’ll give it a try. OpenSUSE is on a separate HDD, so I need to make notes, swap HDD’s and try your tips.

This is what I love, fast friendly honest support! I’ll report back!

No, it doesn’t seem to work, it just does the same as above, with the corruption, so I can’t go any further. My Grub options are:

OpenSUSE 11.2 - (default) with vga=0x314 on boot options line


Desktop, with the same as the first OpenSUSE option

Failsafe: off:highres=off processor.max_cstate=1 x11 failsafe vga=0x314

I’m not sure what all that means, but typing 3 at all of them results in the same event.

Are you certain it was a “good” installation? Did the installation CD/DVD pass the MD5SUM check of the downloaded file vs that posted on the website? Did the burned CD/DVD pass the media check?

All passed OK. Originally I was having trouble with DVD-RW discs, but today burned a DVD-R, and everything was perfect. This DVD-R was used to do a fresh install, and not a repair. I did MD5 match, burn verify, and Check Installation Media when installing.

My hardware’s all good too, Windows 7, Vista and XP are perfect on it.

burning an openSUSE OS to a DVD-RW is typically risky …

Did you burn at the slowest speed your burner allows? That also makes a difference, and problems resulting from a fast burn do not always show up in the Check Installation Media test.

Is this an external HDD or an internal HDD ?

Assuming the installation DVD is good, the only other things I can think of for you to try are:
(a) check your BIOS settings,
(b) check to see if there is a new BIOS available,
(c) if you have any non-essential USB devices connected during the boot, then remove them.

My HDD is internal, my BIOS is up to date, and I didn’t have anything connected via USB, except a mouse. Linux has its own HDD, which is partitioned with 35GB as my /, and a 2GB partition as Swap.

I burned at 3x, which is the speed I burn Xbox games at, without problems. I even used IMGBurn to burn the disc, which has worked for other Linux ISO’s, and Xbox discs.

I might just forget OpenSUSE on this laptop, I really don’t have the time to be fiddling with terminals, commands, and drivers. I was hoping it’d be a complete out-of-the-box mobile Linux experience like it has been in the past, but as usual, nVidia’s **** hardware strikes again. ATi are my favourite, and works on OpenSUSE on my Core i7.

I don’t consider Xbox games a good criteria, but if 3x is the slowest you can burn, so be it.

Did you 1st check to see if anyone else had succeeded in putting any Linux version on the Novatech (Clevo) M670SU before you tried openSUSE ? You could also boot the liveCD and try to see what boot codes it is using for a successful boot (assuming the liveCD boots successfully).

Some hardware just does not work nice with Linux.

I am very conservative in my installs. While my desktop experience with openSUSE-11.2 has been great (primarily due to the Linux friendly hardware I have on desktops) on the two family laptop’s I have kept openSUSE-11.1, as I am not happy with what I have read wrt the hardware on those laptops working with the 2.6.31 kernel (in 11.2) nor with the state of graphic drivers for the Intel and ATI hardware for 11.2 (for the hardware in those laptops).

Linux is Linux, and if you find another distribution works better, than by all means try it. But assuming you checked your BIOS and the installation DVD (and liveCD) and can find nothing, then your approach to go with what works (due to specific manufacturer support and testing with Microsoft operating systems) is by far IMHO a very good approach.

Good luck in your efforts.

What you said about 11.1 triggered something. So I’ve gone and fished out my Linux Format 11.1 coverDVD, and installed it over 11.2. I manually configured the display to be 1440x900, but still got the corruption, BUT, this time, I can see the X cursor1

Failsafe (pae) boots, too! But, every time I try to get the panel to go into 1024x768, it corrupts, and CTRL+ALT+BACKSPACE doesn’t kill the server. I have to turn off then back on, going back into Failsafe.

Slowly, I’m getting there! It’s a 17" panel, native 1440x900, so why that res is corrupting, I’m not sure.

Am I correct that openSUSE-11.1 will boot to run level 3, while openSUSE-11.2 would not boot to run level 3 ? If so, then in openSUSE-11.1 you could try various drivers (and also various resolutions) with 11.1.

I have a desktop (old PCI based) nVidia 8400GS working with openSUSE-11.2 on a PC, … but my motherboard on that PC is very friendly toward Linux, which I suspect makes a major difference.

I provided some practical theory for nVidia drivers here (in post#2):
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

Try typing ‘init 3’ on the options line, instead of just ‘3’. Too much has happened now.

My suggestion: install 11.2 + Linux Kernel Development pattern. Download latest NVIDIA driver, install ‘the hard way’, no sax2, restart X, done.