Graphic package manager not starting

Hello All,

I’ve recently updated to Leap 42.2, and I’m having a peculiar issue with the graphic package manager crashing without giving any error information.
This is the current situation:

I can update/install new packages via zypper
I can update/install new packages using the console version of Yast
If I launch the KDE version of Yast and then select the package manager, it crashes after a few seconds of activity with no error message

Any idea what the problem could be? Is there a way to get some more useful feedback from the crash?

Many thanks in advance

Often is mixed repos show us

zypper lr -d

This is the list of my repos:

They are all activated, as far as I can see they should all be 42.2

I’m on Tumbleweed, but had the same problem: Yast GUI would open, but none of the modules would load. Everything worked fine in the terminal.

I found a recommendation to update the following packages from version 7 to version 8 and it fixed the problem. I don’t know if this would apply to Leap:

sudo zypper in libyui-qt8 libyui-qt-graph8 libyui-qt-pkg8

I just checked and installing version 8 of those packages left the 7 versions in place, so I’ve got both now. I don’t know if that matters, but I just wanted to be clear.


thanks for your help. I confirm that worked for me too