Graphic corruption during install

Hello,

I’m installing OpenSuSE onto a Compaq Presario SR1103WM. I’ve dug around & am using the acpi=off during boot, and watching the output from the installation process. My system makes it to “Configuring X…”, goes through on/off/on/off states on my monitor, finally settling at one of any number of pretty (but sadly useless) arrays of color.

My troubleshooting thus far has been to lower the default resolution to 1024x760 (the on-board card supported higher under Windows XP) and disabling acpi; beyond that I’ve reached the end of my knowledge.

You could have said what the on-board card is. If you tried vesa mode install or even text mode?
If necessary you can run the installer and de-select automatic configuration, which lets you setup things manually.

I’ve now tried VESA & Text mode. The on-board graphics card isn’t identified by HP’s website; the motherboard simply shows as having a ‘VGA’ slot.

As for disabling the auto installation, that isn’t an option I’m presented with at my load screen, which provides the following list:

openSUSE Live (KDE)
Failsafe Settings
Check Installation Media ← Did this, it’s fine
Boot from Hard Disk
Memory Test

If there’s a way to forsake going in to X at all, that would work; the intended purpose for this box is as a ‘lab’ machine, with no GUI really needed.

Once you start the installer you should see such an option (to disable automatic config) fairly early on.

Unfortunately, I’m not seeing any such option. I restarted it in text-mode & followed all 3 terminals carefully, but wasn’t asked for my input at any point (nor did I see a point where I could’ve quickly hit a button).

Each time, the last thing I see is,
Starting HAL Daemon
Creating X Configuration…

then it goes back and forth as if it’s trying to determine appropriate resolution, and finally settles on some meaningless series of vertical stripes.

Thank you for your consistent help, by the way.

Here
Installation/11.1 DVD Install - openSUSE

> If there’s a way to forsake going in to X at all, that would work; the
> intended purpose for this box is as a ‘lab’ machine, with no GUI really
> needed.

then elect to install as a “server” and X won’t even be installed, see
the LAST option at the bottom of this install screen:

http://en.opensuse.org/Installation/11.1_DVD_Install#Step_5:_Desktop_selection


Andy Sipowicz

I’ve checked that link & seen the frames you’re talking about, however, the only graphical screen I see is the one at the top of the page–I never make it far enough to be able to make any of the selections you’re highlighting. Is there an intervention-style argument I can pass at the first screen?

from:Installation Help - openSUSE

If the graphical boot menu doesn’t show or freezes, try press and hold Shift on the keyboard when booting the installation media. This starts the text-mode boot menu instead.

Also, once you select installation from the dvd. I have a feeling you can exit to text mode by hitting Esc. (I’m not certain. And don’t have time at the mo to check)