Grafikprobleme - ATI Radeon HD5670 - fglrx

Hi,
ich hab mir gerade openSUSE 11.3 64Bit installiert und musste leider ein paar Probleme feststellen. Das erste betrifft den Grafiktreiber fglrx. Ich habe die Pakete:

x11-video-fglrxG02
ati-fglrxG02-kmp-desktop
für meine ATI Radeon HD5670 installiert. Danach hab ich die Kommandos

ldconfig
aticonfig --initial --input=/etc/X11/xorg.conf

als root ohne laufendem XServer eingegeben. Gleich danach hab ich rebootet.** fglrxinfo** zeigt mir an, dass der Treiber geladen wurde und die Desktopeffekte funktionieren auch. Nun zu meinem Problem. Ich hab ständig Grafikfehler (auch wenn ich die Arbeitsflächeneffekte deaktiviere).
Die ersten zwei Bilder zeigen Rechtecke, die beim Verschieben, Scrollen etc. auftauchen. Das dritte Bild bekomm ich beim Herunterfahren anstatt des openSUSE Splashs.

Ich bitte um eure Hilfe!
Danke!

http://www.bilder-hochladen.net/files/a3yq-19.jpg
http://www.bilder-hochladen.net/files/a3yq-1a.jpg
http://www.bilder-hochladen.net/files/a3yq-1b.jpg

Das ist das alte Problem mit den neuen 2D Treibern. Du kannst den alten 2D Treiber aktivieren, indem Du als Root folgenden Befehl absetzt:

aticonfig --set-pcs-str=DDX,ForceXAA,TRUE

Danach neu starten. Allerdings ist das Reskalieren von Fenstern etwas ruckelig.

cu
Gargi

Danke, ich teste es heute noch und sag dann gleich bescheid. Ich hab noch ein zweites Problem, das mit zu schaffen macht: Verbindungsabbrüche - TP-Link TL-WN321G

Ich hab eine bessere Lösung gefunden, die auch super funktioniert:
openSUSE 11.3

Ich hab einfach den neuesten Grafiktreiber installiert und jetzt gehören die Grafikprobleme der Vergangenheit an.

Probiers aus, allerdings hat der neue Treiber bei meiner 5770 nichts gebracht, blieb bei obigen Fehlern.

Ja, wie du sagst hat es nichts genutzt, hab es aber erst später bemerkt. Ich hab den alten 2D Treiber genommen, so wie du es mit empfohlen hast. Danke für deine Hilfe.