GrADS fails to plot contours

I’m running openSUSE 13.2 on a Dell Optiplex and on a Lenovo X220t. On both machines GrADS (Grid Analysis and Display System) 2.1.a3 is failing to plot contours (merely plotting contour labels). On another forum I was told that this “sounds like a familiar bug that was associated with cairo rendering in X11.” I’ve since tried a number of steps, without making any progress. Does anyone have any related experience? Thanks, John.

PS. GrADS ( http://iges.org/grads/ ) “is an interactive desktop tool that is used for easy access, manipulation, and visualization of earth science data.” I’ve had no problems with earlier releases 2.1.a1 and 2.0.

Hi there,

I installed grads 2.1.a3 on Suse 13.2 and followed the tutorial steps at http://iges.org/grads/gadoc/tutorial.html and was able to produce the contour plot. Contour lines were displayed, however there were sections missing

http://ytmnd.timelordz.com/grads-contour-plot.png

and I got the output:

Error opening stroke character data set
Data set names = /usr/local/lib/grads/font0.dat ; font0.dat

Was that your result as well?

ldd bin/grads on the binary shows it links to everything:

~/grads-2.1.a3> ldd bin/grads 
        linux-vdso.so.1 (0x00007fff071fc000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007fa776a65000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007fa776853000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fa776635000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007fa776431000)
        librt.so.1 => /lib64/librt.so.1 (0x00007fa776229000)
        libm.so.6 => /lib64/libm.so.6 (0x00007fa775f27000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007fa775c1f000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007fa775a08000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fa775660000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fa776dc9000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007fa775440000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007fa77523b000)

Hi… no, I don’t even get segments of contours, merely the contour labels. I couldn’t swear that I didn’t once or twice get contours (I’ve been through this so many times in the last couple of weeks I’ve lost track) but at present it’s reliably none. My install process was very brief:


gunzip /home/.../download/GrADS/grads-2.1.a3-bin-CentOS5.11-x86_64.tar.gz
tar xvf /home/.../download/GrADS/grads-2.1.a3-bin-CentOS5.11-x86_64.tar

There is no error message, I don’t believe. However I will try again and update this.

As I’d thought, there’s no error message associated with this problem… I just tried to plot contours of the height of the 850 hPa surface (d hgtprs), and I get nothing but the contour labels. Curiously though, and I only just now observed this, if I resize the GrADS window (using the mouse) then repeat the d hgtprs, I do get contours, but only over a fraction of the domain. I’ve tried using both the XFCE and the KDE GUIs, that makes no difference.

Video card, driver???

YaST Hardware identifies:

Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
Driver: i915

The driver would be the openSuSE 13.2 default I guess. I haven’t changed it. Thanks, J

The info below applies to the Dell Optiplex PC… on the Lenovo X220t laptop, YaST identifies: 2nd Generation Core Processor Family Integrated Graphics Controller

Just on the off chance there is something weird, could you post output for:

 ldd bin/grads 

Hi – looks like yours I think? Thanks, J

>cd /usr/local/bin/grads/grads-2.1.a3/
>ldd bin/gr
grads* grib2scan* gribmap* gribscan*
>ldd bin/grads
linux-vdso.so.1 (0x00007fffee7fc000)
libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f1f90110000)
libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007f1f8fefe000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f1f8fce0000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007f1f8fadc000)
librt.so.1 => /lib64/librt.so.1 (0x00007f1f8f8d4000)
libm.so.6 => /lib64/libm.so.6 (0x00007f1f8f5d2000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f1f8f2ca000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f1f8f0b3000)
libc.so.6 => /lib64/libc.so.6 (0x00007f1f8ed0b000)
/lib64/ld-linux-x86-64.so.2 (0x00007f1f90479000)
libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f1f8eaeb000)
libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f1f8e8e6000)