GPU Driver problem AMD RADEON R5 430

Hey everyone, new member here.

Been using opensuse for a few years now (but far from being an expert), but since i bought a new laptop some issues emerged and it seems i can’t get a hold of them.

When i first installed Opensuse Leap 42.1 with KDE the computer was freezing every 15 minutes or so, figured out that it froze whenever something needed GPU to work.
Installed the system again with GNOME, worked better but every now and then the computer freezes.
When i check my details i see that the default GPU is the one integrated in the processor and not the AMD card i have in it.

I cant seem to make the graphics work the way they are supposed to. Any advices?

HP G5 250
Intel® Core™ i5-6200U CPU @ 2.30GHz Skylake
AMD Radeon R5 M430

Try 42.2 or better Tumbleweed probably the problem is the skylake processor though could also be the hybrid graphics (Intel+AMD GPU)

With 42.1 I think you can still get the fglrx AMD driver (not available in 42.2 or above) which does support hybrid. Not at all sure about the newer AMDGPU drivers