GPU Acceleration not working (used ATIUpgrade install script)

I tried running:
HTML5 Fish Bowl

and I get only 8fps in Firefox and Chrome and 4fps in Opera. They rely on the GPU acceleration of the graphics driver. I installed ATIUpgrade (See: ) to properly install the drivers. It ran perfectly (I installed them months ago with atiupgrade) with no errors. However, I’m clearly not getting hardware acceleration.

I tried running atiupgrade again today (to see if there were any updates) and got the response:

(1) - Analyzing system...
* Found ATI graphics card: AMD Radeon HD 6410D
/usr/bin/atiupgrade: line 324: AMD Radeon 6 * 1: syntax error in expression (error token is "Radeon 6 * 1")

My System info:

Vendor:  ATI Technologies Inc
2D driver:  fglrx
3D driver:  ATI

OS:  Linux 3.1.10-1.16-desktop x86_64
System:  openSUSE 12.1 (x86_64)
KDE:  4.8.5 (4.8.5) "release 522"

Processor (CPU):   AMD A4-3400 APU with Radeon(tm) HD Graphics
Speed:  2,700.00 MHz
Cores:  2

Total memory (RAM):  11.5 GiB
Free memory:  8.2 GiB (+ 1.4 GiB Caches)
Free swap:  3.8 GiB

ATIUpgrade Version: atiupgrade-5.2-3.1.noarch

Does anyone know if there’s anything I can do?