GPT MBR Mismatch

I outlined this problem in another thread under hardware but I think it might be more suited to Applications. I did a very stupid thing and tried to do something myself without waiting for guidance. After adding 2 more HDDs to my RAID card I used the storage manager program to extend the array onto the drives. I then attempted to grow the partition to match but was stymied because after extending the array the backup GPT was in the wrong place. I tried to move it by using

sgdisk -e /dev/sdb1

which only too late I realized was stupid because I needed to run the command on /dev/sdb not sdb1. Anyway, sure enough the system will now no longer recognize the file system. When I run gdisk on the array I get:

GPT fdisk (gdisk) version 0.6.14

Partition table scan:
  MBR: hybrid
  BSD not present
  APM: not present
  GPT: present

Found valid GPT with hybrid MBR; using GPT.

Command (? for help): v

Warning! Mismatched GPT and MBR partition! MBR partition 1, of type 0x83, 
has no corresponding GPT partition! You may continue, but this condition 
might cause data loss in the future!

Identified 1 problems!

Granted, I have all my really important files backed up, but it would be a real pain to lose the non-essential stuff. Is there any way that what I did can be un-FUBAR’d? Any advice at all would be VERY appreciated.

I now believe that this error isn’t due to a problem with the GPT. I think it’s a file system issue. I’m currently running fsck on the array. It recognized that there was a damaged filesystem and is attempting to correct it. Due to the size of the array this could take quite awhile. Anyway, here are my thoughts, albeit probably wrong ones. Are the superblocks for the ext4 filesystem put at the end of a partition? Did I inadvertently overwrite the superblocks when I accidentally ran

sgdisk -e /dev/sdb1

instead of

sgdisk -e /dev/sdb

That’s the only thing I can think of… Hopefully fsck works… I wish someone would respond. I usually get a response within minutes on here and the one time I really need help all of a sudden no one’s answering me. I hope my question wasn’t so moronic no one thought it worth their time to answer…

On 08/20/2011 05:16 PM, nicktlloyd wrote:
> I hope my question wasn’t so moronic no one thought it
> worth their time to answer…

no, i don’t think it is moronic…unfortunate that you need to ask it,

i can’t help which is why i didn’t ‘answer’ hours ago…(it is saturday,
you know…why not hop on to IRC (see
<>) and ask there…

[it is there that the real gurus (without a life) live on weekends :)]

btw: the only time i ever had superblock problems, fsck didn’t
help…mainly (i think) because i needed to buy a new drive before the
supers went south… ymmv and you may ‘only’ need to format and
install…or, hold out for someone with magic to appear here…or there.

wish i could help.

DD Caveat
openSUSE®, the “German Engineered Automobile” of operating systems!

i am unable to understand exactly what type of setup you have with your raid card and storage, but i can sympathize with your predicament. Similar situation happened to me months ago trying to extend a lvm2 volume i had transferred to a larger drive.

the lvm2 commands (pvextend and lvextend) executed without error, but the filesystem was inaccessible until i discovered my mistake and used resize2fs to make the filesystem match what the volume actually was.

may not apply in your case, but that was my solution.

Thanks for taking the time to answer. I think I will definitely look into IRC. I finished running fsck and it’s working again and I was able to grow the partition properly. It makes me a bit nervous that fsck made me answer “y” to a whole bunch of stuff I had no clue about but it’s working so I’m just going to be that much more vigilant about backing up in the future. Actually, although it really seems like I’ve been running into all kinds of problems lately, each one of them has really forced me to learn aspects of Linux I didn’t really know about before. Because of today’s adventures and all the digging on the net I had to do I’m a LOT more knowledgeable about partitions, file systems and openSUSE in general. I’m still very much in the dark as to why the problem happened although my earlier guess is still uppermost in my mind, but in all seriousness I’m somewhat glad it happened. I really do just have a lot to learn.

On 08/20/2011 08:06 PM, nicktlloyd wrote:
> I really do just have a lot to learn.

btw: thank you for your service.

openSUSE®, the “German Engineered Automobile” of operating systems!