GPRS/EDGE mobile based internet connection on openSUSE 11.1

Hello all

Could anyone please give me a tutorial about setting up internet
connection using GPRS/EDGE enabled mobile on openSuSE 11.1 (gnome) ?

I have downloaded openSuSE 11.1 gnome live CD and tried many ways to connect to the internet using my SonyEricsson k550i. The network manager applet on Ubuntu 8.10 or Linux Mint 6 was very handy and could let me connect to the internet using the mobile right away from the live CD, just had to specify GrameenPhone * as the operator. But in openSuSE 11.1, the network manager could not find any network operator when I command it to ‘SCAN’ for networks. Moreover, it somehow deletes all the data accounts from my mobile itself and set my mobile in ‘FLIGHT MODE’.

Anyway, then [after rebooting] I tried to use YaST2 modem setup to configure the mobile modem manually. But still no luck. No internet connection could be established. But the data accounts were intact and my phone was not set to flight mode.

Then I tried the command “wvdialconf” and edited “/etc/wvdial.conf” thereafter. This time the computer connects to the mobile phone. But if I ping any site, it says “cannot resolve hostname”. After getting this message, I edited the “ip-up.local” file as following a tutorial
like this:

cat > /etc/ppp/ip-up.local
#!/bin/sh
mv /etc/resolv.conf /etc/resolv.conf.bak
cp /etc/ppp/resolv.conf /etc/resolv.conf
chmod 644 /etc/resolv.conf
<press Ctrl-D here>
chmod +x /etc/ppp/ip-up.local

But still no luck.

Then I manually edited “/etc/resolv.conf” and “/etc/pppresolv.conf” files to include nameservers. Then wvdial worked.

Could anyone please help connect to the internet
from openSuSE 11.1 in an easy way like Ubuntu 8.10 using network manager 0.7?*