gpro-ftpd install..help please

i’m trying to install gpro-ftpd, since im not really getting anywhere with proftpd, and I would like a more user friendly FTP server.

this is what I typed: zypper up install gproftpd-8.2.2-1.rhfc4.nr.i386.rpm

and this is what it said:
Retrieving repository ‘google-chrome’ metadata …[done]
Building repository ‘google-chrome’ cache …[done]
Loading repository data…
Reading installed packages…
‘in’ not found in package names. Trying capabilities.
No provider of ‘in’ found.
‘gproftpd-8.2.2-1.rhfc4.nr.i386.rpm’ not found in package names. Trying capabilities.
No provider of ‘gproftpd-8.2.2-1.rhfc4.nr.i386.rpm’ found.
Resolving package dependencies…

Nothing to do.

gpro-ftpd is downloaded, and in teh download folder. I tried to find it in the install/remove software program, and it didn’t find it. So, any suggestions on what i’m doing wrong? OR, any suggestions on a better user friendly FTP server? since im new to FTP, and linux, I need it to be very user friendly.

thanks

On Mon, 04 Feb 2013 19:26:02 +0000, Sweettea wrote:

> zypper up install gproftpd-8.2.2-1.rhfc4.nr.i386.rpm

That’s not a valid zypper command - you’ve given it two separate actions
to do, and you need to specify either “update” (up) or “install” (in).

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

On 2013-02-04 21:34, Jim Henderson wrote:
> On Mon, 04 Feb 2013 19:26:02 +0000, Sweettea wrote:
>
>> zypper up install gproftpd-8.2.2-1.rhfc4.nr.i386.rpm
>
> That’s not a valid zypper command - you’ve given it two separate actions
> to do, and you need to specify either “update” (up) or “install” (in).

Also the rpm is already downloaded into a local directory, and of
course, it is ignored unless that directory is added as a repository.
Plus, I doubt that the rpm is an openSUSE rpm: the “rhfc4” in the name
suggest that it is for red hat.

Sweettea, find the rpm you want to install in a standard openSUSE repo
and install from there.

As to suggestions to an easier FTP server, YaST has an FTP server
module: just install it and use it.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

ty for the responce. I fixed my install issue with terminal. and i now have a GUI. when i click on the GUI, i get this message:

KDEInit could not launch ‘gproftpd’:
Could not find ‘gproftpd’ executable.

at the end of the terminal install, i got this message:
Installing: gproftpd-8.2.2-1.rhfc4.nr …[done]
Additional rpm output:
warning: /var/cache/zypp/packages/tmpRPMcache/gproftpd-8.2.2-1.rhfc4.nr.i386.rpm: Header V3 DSA/SHA1 Signature, key ID b8693f2c: NOKEY

not sure if ^^this has anything to do with it.

On 2013-02-04 23:36, Sweettea wrote:

> not sure if ^^this has anything to do with it.

No, and I know nothing about that ftp server, can’t help you further, sorry.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

How can a FTP server be user friendly.FTP server should just support all the FTP commands and should support secure logging in etc…
I can understand “friendly” if it is a FTP client like having a GUI etc…

On 2013-02-05 03:56, vazhavandan wrote:
>
> Sweettea;2524510 Wrote:
>> user friendly FTP server.thanks
> How can a FTP server be user friendly.

As in “easy to configure”. If you talk with Windows people, it means
having a nice GUI.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Are you talking about a FTP client??

Set it up vi yast then manage via a client. even Dolphin an be used to add remove files etc to a local or remote FTP

Setting up usually just require setting permissions any way