gPodder 2.14 problems

Since Amarok 2–among it’s many, many issues–cannot handle copying podcasts to my iPod 5, I’ve turned to Gnome’s gPodder despite my preference for KDE apps.

gPodder worked excellently until yesterday when with each podcast’s refresh attempt I get a failure message that “global name ‘keymap’ is not defined”

I’ve been using gPodder 2.14 since my upgrade of SuSE 11.3 to 11.4 (and maybe under 11.3; I don’t recall). It had been working fine (and fine with 11.3). I tried updating it, and was told that “nothing provides python-pymad needed by”, which is the first indication I’ve had that something was missing (as I said, it had worked). So I deleted it, switched to the new Packman repository, and reinstalled. Same warning on python-pymad, same “global name ‘keymap’ is not defined” error.

Any ideas? Fixes? What is and where is python-pymad? Could that be the issue, but if so why did it run fine up till now?

As I posted on the gpodder bugs page:

Problem is not gpodder (or python-pymad), but python-feedparser package. Having quickly looked into this further, it seems to be related to:

“python-feedparser” package 4.1-6.3.1 (5th April 2011 build)

uninstall this and revert back to version 4.1-5.1

I’m not sure if this version is in the openSUSE 11.4 repos, as I’m still running 11.3 here at the minute. There may be a newer version, but I don’t have time to check.

This should solve your problem.


Thanks, Richard (and Thomas on the gPodder list). That fixed it.

The python-feedparser that openSuSE 11.4 installs is called
python-feedparser-4.1-9.10.1.noarch built Thu 07 Apr 2011 11:14:41 AM EDT.
Maybe that correlates to something, but it doesn’t fit the versioning you describe.

Anyway I uninstalled this python-feedparser via YaST2 (forcing break dependencies). I found
python-feedparser-4.1-5.1.noarch.rpm but was unable to force installing it:

rpm --install --force python-feedparser-4.1-5.1.noarch.rpm

error: Failed dependencies:
python = 2.6 is needed by python-feedparser-4.1-5.1.noarch
python(abi) = 2.6 is needed by python-feedparser-4.1-5.1.noarch

python 2.7 something is installed. (Sigh, maybe I will switch to Unbunto.)

Anyway, I downloaded feedparser-5.0.1.tar.gz and installed that. I ran gPodder
2.14. My podcast podcast updated and I was able to download new episodes.

For anyone having similar issues, see

I have gpodder 2.13 and python–mygpoclient 1.51 installed with python-feedparser 4.1-9.10.1 noarch installed on 11.4, and apart from breaking the dependencies, because python-pymad was not available, gpodder is working well.

Apparently, when I ran YasT security updates/patches I also updated python-feedparser as well. However, this weekend, I had no clue as to why gpodder quit downloading my pod casts. Today I verified that I was the only one having a problem so it had to be something on my end. just as a test I deleted my subscriptions and when I attempted to re-subscribe I got the error ‘keymap’ is not defined.

A key word search for ‘keymap’ is not defined, brought me your your Q&A’s THANK YOU !!

Down grading python-feedparser 4.1-2.3.1 to python-feedparser 4.1-2.1 solved my problem.
Thank you
openSUSE 11.2 gPodder 2.13


This solution worked for me on Open Suse 11.4

I uninstalled python-feedparser breaking the gpodder dependency, downloaded feedparser-5.0.1.tar.gz from feedparser-5.0.1.tar.gz - feedparser - feedparser-5.0.1.tar.gz - Universal Feed Parser - Google Project Hosting

I installed it as root.

gPodder now works without keymap errors that were occurring on some of my feeds.