GPG and Gnome Apps

I don’t know if it will solve your problem. But you could try switching from “gdm” to “kdm”. You might first need to install “kdm”.

After login to Gnome, you will probably then need to manually open the login keyring (via seahorse as application).

When you login to Gnome from KDM, the real “gpg-agent” is started instead of the seahorse emulation.

Tried but didn’t change anything.

I am no gpg expert but I am using gpg2 and I thought it is fully compatible with gpg1 - is there any reason then to keep gpg1? I can exchange encrypted emails with a friend who is using gpg1 on Slackware without problems. I just tried to sign a textfile:

uli@linux-dfsr:~/Documents> gpg2 -sab InterfaceNames.txt 
gpg: enabled debug flags: memstat

You need a passphrase to unlock the secret key for
user: "Uli Fuerst (......) <>"
2048-bit RSA key, ID 4C63D087, created 2013-07-13

random usage: poolsize=600 mixed=0 polls=0/1 added=5/88
              outmix=0 getlvl1=0/0 getlvl2=0/0
secmem usage: 1408/32768 bytes in 3 blocks
uli@linux-dfsr:~/Documents> cat InterfaceNames.*
 * Predictable network interface device names based on:
 *   ID_NET_NAME_PATH=enp0s29u1u2
Version: GnuPG v2

uli@linux-dfsr:~/Documents> ls InterfaceNames.*
InterfaceNames.txt  InterfaceNames.txt.asc

After using the passphrase the signature file was created. I use KDE and there using Kmail where GPG is fully integrated. I put the encrypt and sign buttons in the toolbar and (lucky for me) so far no problems here.

I would strongly discourage this. GNOME does not support alternative display managers.

If you read my earlier posts in this thread, you’ll see that’s not the case. GNOME 3.16 and earlier is incompatible with gpg2.

Anyway, GNOME 3.18 on up will be compatible with gpg2 but no longer compatible with the original gpg. This is very good news for openSUSE: it means you’re not doomed to broken gpg integration anymore. See: