Got screwed after update, again.

The last time was grub that got messed up, this i believe is the kernel.

Now past the grub, when tying to load Suse i get this

I’m still googling around, so far i was able to find this, which seem quite dated and require /boot to be in /, unfortunately i have /boot in a separate partition and the user seem to be running the old grub.

i need a solution that can be executed from the livecd (usb), with chroot or whatever.

Don’t know if this helps:

linux:/etc # fdisk -l

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00053535

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048   114690047    57344000    7  HPFS/NTFS/exFAT
/dev/sda2       114690048   169768959    27539456   83  Linux
/dev/sda4   *   169771006  1953519615   891874305    5  Extended
/dev/sda5       172036096  1953519615   890741760    7  HPFS/NTFS/exFAT
/dev/sda6       169771008   171724799      976896   82  Linux swap / Solaris
/dev/sda7       171726848   172023807      148480   83  Linux

Partition table entries are not in disk order

Disk /dev/sdb: 4009 MB, 4009754624 bytes
64 heads, 32 sectors/track, 3824 cylinders, total 7831552 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x21e53f60

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          64     1900543      950240   83  Linux
linux:/etc # df
Filesystem     1K-blocks     Used Available Use% Mounted on
devtmpfs          487784       16    487768   1% /dev
tmpfs             513856       88    513768   1% /dev/shm
tmpfs             513856     2976    510880   1% /run
/dev/sdb          949592   949592         0 100% /livecd
/dev/loop0       3553952  3132548    421404  89% /
tmpfs             513856        0    513856   0% /sys/fs/cgroup
tmpfs             513856     2976    510880   1% /var/lock
tmpfs             513856     2976    510880   1% /var/run
/dev/sda2       27107196 10922800  15137900  42% /run/media/linux/0b5b4171-e430-4579-abac-3d91de444921
/dev/sda2       27107196 10922800  15137900  42% /var/run/media/linux/0b5b4171-e430-4579-abac-3d91de444921
linux:/etc # cat /var/run/media/linux/0b5b4171-e430-4579-abac-3d91de444921/etc/fstab
/dev/disk/by-id/ata-SAMSUNG_HD103SJ_S246J90Z913185-part6 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-SAMSUNG_HD103SJ_S246J90Z913185-part2 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-SAMSUNG_HD103SJ_S246J90Z913185-part7 /boot                ext4       acl,user_xattr        1 2
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

Please mount your /boot partition and check that it is not full:

mount /dev/sda7 /mnt
df

If it **is **full, you still should be able to select an older kernel in the bootmenu which should work, though.
Boot into that and post the output of the following, so I can give you further instructions:

rpm -qa | grep kernel

I still don’t understand the obsession with a seperate /boot partition in the installer by default - every single machine that even runs 12.3 nowadays can boot from multihundred gigabyte-or-terabyte partitions without issues.

Well, that’s embarrassing. Booting on an older kernel just slipped my mind.

sda7 is at 73%

rpm -qa | grep kernel
kernel-default-3.7.10-1.4.1.i586
kernel-default-3.7.10-1.11.1.i586
kernel-firmware-20130114git-1.2.1.noarch

Does it do that by default? I never had a seperate /boot partition on any of my systems, and I can’t remember having the installer ever propose one (not even when I installed openSUSE 12.3RC1 in a VM to test it).

So there seem to be 40MB free. Not sure if that’s enough for a kernel/initrd combo on 12.3.

At least your error message would point to a corrupted initrd.
I guess you had kernel-default-3.7.10-1.1 installed as well when you installed the new kernel and your partition got full while creating the initrd. Now that 3.7.10-1.1 is removed, there should be enough space.

So try to remove kernel-default-3.7.10-1.11.1 and install it again…

I did install/reinstall the kernel with yast2 and the issue persists. The only difference is that kernel-default-3.7.10-1.4.1.i586 got erased (the one that worked), and it left me with 3.7.10-1.11.1, so i’m back on the live usb.:frowning:

Why would it do that? Don’t you have multiversion kernels enabled?

Well, you could try to fix that when in the live usb session like that:

  • download the kernel-default-3.7.10-1.4.1.i586.rpm package from Index of /update/12.3/i586
  • mount your harddisk root partition to anywhere (let’s say /mnt)
  • mount your boot partition to /mnt/boot
  • install the kernel package with
sudo rpm -Uvh --force --root /mnt kernel-default-3.7.10-1.4.1.i586.rpm

That should hopefully bring you back a bootable kernel…

I seem to remember having to upgrade my mkinitrd to get one of my kernels updated. Have a read over this old thread it may give you some ideas.

In the meantime, while on the live-usb, i’ve mounted dev/sda2 (root) and with chroot i mounted /sys, /proc and /dev/sda7 /boot. With zypper i’ve reinstalled the kernel and the end result is:

rpm -qa | grep kernel
kernel-default-base-3.7.10-1.11.1.i586
kernel-desktop-3.7.10-1.11.1.i686
kernel-firmware-20130114git-1.2.1.noarch

In the grub menu, I have kernel-desktop-3.7.10-1.11.1.i686 as default, while kernel-default-3.7.10-1.11.1.i586 as second option. I can boot into any of them successfully, except on kernel-default-3.7.10-1.11.1.i586 i end up with not network connection (no wired device or adapter visible, like if my modem was unplugged).

I don’t know the difference between kernel-desktop and kernel-default is. I mean, i read the description but i’m not sure of the implications on my system and if is going to create problems in the future. Should i leave as it is or to do what you two have suggested?

On 05/31/2013 12:36 PM, Penguin Warrior wrote:
>
> Got screwed after update, again.

with emphsis on the again how are you “updating” and what are you
“updating”…

if you ever get it running right again try this:

disable package kit, apper or whatever that thing is in “the tray” or
“the panel” which pops up and says there are updates…and, then
once a day run either (your choice) “zypper patch” [NOT “zypper up”]
or YaST Online Update and install all the security patches they say
you need…

and, i guess your “screwed up again” will be pretty much over…

UNLESS you are running Tumbleweed, in which case you posted to the
worng forum.


dd
http://tinyurl.com/DD-Caveat

That’s kernel-default-base, that is missing most of the kernel modules (that’s why you’re network is not working). Install kernel-default instead if you want to use the “default” kernel.

The kernel-desktop is more finetuned for desktop usage. But otherwise they are similar.

So choose between kernel-default and kernel-desktop and remove the other…

If kernel-desktop is working fine now, I’d suggest to keep that.

I’ll suggest an amendment to that.

You (Penguin Warrior) probably have two kernel versions installed, namely 3.7.10-1.11 and 3.7.10-1.4. As soon as you are satisfied that 3.7.10-1.11 is working well, remove 3.7.10-1.4. You can do that with Yast software management (use the Versions tab).

It seems likely that your “/boot” has enough space for two kernels, but not for 3. The way updating is working, a new kernel will be added, and the oldest unneeded old kernel will not be removed till after the next boot. So if you keep two kernels around, you will run out of space on every kernel update. If you only keep one kernel around, you should be fine.

If you want to play it extra safe, then when you see a kernel update (with Yast online updates), cancel out, and then check whether you have additional older kernel versions that can be removed. If you do, then remove those before you return to online update to complete the kernel update.

On 05/31/2013 11:16 PM, nrickert wrote:
> As soon as you are satisfied that
> 3.7.10-1.11 is working well, remove 3.7.10-1.4.

+1


dd

Would this be a step backward? I have not read the whole thread but *.10-1.4 is newer kernel correct?

It’s newer than what you show in your signature. But it is older than 3.7.10-1.11, which came out as a security bug fix around a week ago.

On 06/04/2013 01:46 AM, anika200 wrote:
>>> As soon as you are satisfied that
>>> 3.7.10-1.11 is working well, remove 3.7.10-1.4.
>
> Would this be a step backward? I have not read the whole thread but
> *.10-1.4 is newer kernel correct?

no.

look at it this way, where all numbers are exactly the same except
for the last (fourth) field:

3.7.10-1.11
3.7.10-1.4

so, since 11 comes after 4 (when counting up), the one with .11 is
newer than the one with any number smaller than 11 (and older than
any one larger than 11)


dd

On 2013-06-04 07:41, dd wrote:
> On 06/04/2013 01:46 AM, anika200 wrote:

>> Would this be a step backward? I have not read the whole thread but
>> *.10-1.4 is newer kernel correct?
>
> no.
>
> look at it this way, where all numbers are exactly the same except for
> the last (fourth) field:
>
> 3.7.10-1.11
> 3.7.10-1.4
>
> so, since 11 comes after 4 (when counting up), the one with .11 is newer
> than the one with any number smaller than 11 (and older than any one
> larger than 11)

The confusion might come from using .4 instead of .04 - you see, in math
…4 is the same as .40 and comes after .11 :wink:

But this not numbers, but strings separated with dots.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On 2013-05-31 13:36, Miuku wrote:
>
> I still don’t understand the obsession with a seperate /boot partition
> in the installer by default - every single machine that even runs 12.3
> nowadays can boot from multihundred gigabyte-or-terabyte partitions
> without issues.

AFAIK, it is not done by default anymore - unless you happen to have
LVM, RAID≠2, or encrypted root. In those cases you need a separate /boot
partition.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On 06/04/2013 02:13 PM, Carlos E. R. wrote:
> in math 4 is the same as .40

haha! i didn’t think about that…

so to anika200:
in software version numbering the below are arranged in newest at the
top to oldest at the bottom

3.7.10-2.1
3.7.10-1.90
3.7.10-1.40
3.7.10-1.11
3.7.10-1.9
3.7.10-1.4
3.7.10-1.1


dd

Yea, that is exactly what I was thinking. Got in now, thanks.