Got `no such cryptodisk found` after broke my dual-boot laptop

The problem

I have dualboot between Windows 8.1. and OpenSUSE TumbleWeed with encrypted harddisk.
And now, when I try to boot the laptop - I get this error:

GRUB loading..
Welcome to GRUB!

error: no such cryptodisk found.
error: disk 'cryptouuid/...' not found.
Entering rescue mode...
grub rescue> _

How I got here:

I wanted to increase the Windows partition size, so I shrinked the Linux one. Thus some unallocated space appeared at the end of the harddisk. And I wanted to add it to the Windows partition, while the Linux one is between them. Which caused the corruption :frowning: … (Didn’t know it will … so stupid …)

The state at the moment:

These are the partitions at the moment:
https://i.postimg.cc/fJrBjP8C/Grub-problem-2.jpg](https://postimg.cc/fJrBjP8C)

sda4 is my Suse partition. I can see all my files there when I open it with file manager and enter the password for it. So my hope is that I’ll be able to restore the things as they were before and not have to re-install everything again.

What I tried so far:

I followed a tutorial found and so - I booted Manjaro from USB (cause I got only that at that moment), mounted the Linux partition on /mnt and also /dev, /sys and /proc to /mnt/(dev|sys|proc) … then I did chroot to /mnt and tried update-grub. Manjaro doesn’t have update-grub command so I found that I have to do grub-mkconfig -o {path-to-grub.cfg}.
I tried, it gave me a lot of errors and no result.

Anything else I can do? … Any help will be appreciated.

Boot live Linux, run boootinfoscript (https://github.com/arvidjaar/bootinfoscript/), upload results to https://susepaste.org

You are short on details, so I am guessing. The output from

fdisk -l

might have been helpful.

My guess: that this is a traditional BIOS/MBR formatted disk (so not GPT partitioning).

I am also guessing that “grub2” is installed to boot from the MBR.

Moving the partition may have caused the problem. It may have caused other problems that you have not yet discovered. I’m assuming that you moved the partition (“/dev/sda4”) while it was encrypted. I’ve never tried that.

… then I did chroot to /mnt and tried update-grub.

Let clarify there. When you “chroot” into an openSUSE system, you are pretty much using commands from openSUSE, not from Manjaro. And openSUSE does not have “update-grub” and it does not have “grub-mkconfig”. It does have “update-bootloader” and “grub2-mkconfig”.

You probably need to reinstall grub2. But I see that arvidjaar has just replied, so I’ll wait for a while before commenting further.

I got 404 page when I tried to create my susepaste, so I created a paste on a different place:

Also, for the other reply, I ran fdisk -l and I got this:

https://pastebin.com/DC3yu05d
And yes, I ran “grub2-mkconfig” actually.

And thanks for looking into this :slight_smile:

/dev/sda1        A6FA-7092                              vfat       SYSTEM
/dev/sda2        1A08019608017255                       ntfs       Windows
/dev/sda3        C090CFA090CF9AF4                       ntfs       
/dev/sda4        6e0637a3-2cd0-4411-8923-1bbea143a68a   crypto_LUKS 
/dev/sda5        60F8C9E0F8C9B496                       ntfs       Extended

Where sda5 comes from? Please provide full output of “dmesg” after booting live Linux.

Oh, wait:

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System 
/dev/sda1                  63         2,047         1,985  **42** **SFS**
/dev/sda2    *          2,048       718,847       716,800  **42** **SFS**
/dev/sda3             718,848   131,475,455   130,756,608  **42** **SFS**
/dev/sda4         131,475,456 1,000,213,167   868,737,712  **42** **SFS**

You converted your disk to Windows Dynamic Disk. This means old partitions no more exist - you have volume manager and on top of it you have partitions. grub2 may be able to work with it, but it requires ldm driver (which is not present).

You really need to decide what you are going to do. Personally I’d convert disk back to basic. Dynamic Disks (or LDM support) is on best efforts level.

If you decide to stay with LDM, you need to (try to) reinstall grub. But I honestly do not know whether this will work.

sda5 is the unallocated space that was created when I shrinked my main linux partition - sda4. And it’s ntfs because I tried to add it to the main Windows partition - which is now sda3 I think.

Here is the result of dmesg:

=====

So - you’re recommending converting back to dynamic disk? … And if so - how can I do that?

After I backed up all the important information - I tried a couple of other things. Now, after I deleted the partitions from the Windows - I get this when I run sudo lsblk -f from the live USB:

crypto LUKS problem 002 — Postimages](crypto LUKS problem 002 — Postimages)

The UUID that starts with 6e0637… - is what can not be found upon booting.

But when I check the fstab on the old OpenSUSE partition - it has only this info:

crypto LUKS problem 001 — Postimages](crypto LUKS problem 001 — Postimages)Does that mean that if I fix the fstab file - it’ll be able to boot correctly into Suse? And if so - can I use a command that will automatically fill the fstab with the correct info?