Got no sound

I’m running tumbleweed. Few updates ago (yesterday) i’ve booted my computer with no sound (3.9.7… kernel)
Next update brings me 3.10 kernel, but no sound.

I’ve tried to launch system with 3.9.5, event with 3.7.10, but i’ve got no sound. Reconfiguring soundcards aren’t helping.

dmesg shows nothing strange.
Everything looks like it’s all working, except that there is no sound.
Normaly i’m not using pulse, but even with it, i see playback in pavucontrol, but no sound.

Rebooting to windows shoes that soundcard is working.

My alsa info: http://www.alsa-project.org/db/?f=9f27a154a89a989a971592b41e50b8ea52f0a3cf

So, any ideas?

Your PC’s hardware audio configuration is complex, with 3 audio devices. Which one are you trying to use ?


!!Soundcards recognised by ALSA
!!-----------------------------

 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfe024000 irq 16
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfbffc000 irq 19
 2 [Creative       ]: HDA-Intel - HDA Creative
                      HDA Creative at 0xfdafc000 irq 18

I see nothing wrong with the motherboard audio, nor with the HDMI (nvidia) audio hardware settings. The Creative card is very complex and has a couple of settings I do not understand:


Simple mixer control 'HP/Speaker',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'HP/Speaker Auto Detect',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]

with playback OFF in 2 places. If you are using card-2, have you tried unmuting those?

Also, given your PC has 3 audio devices, which one are you using to try and send sound ?

If you have a spare set of speakers, plug them into the unused audio out and check to see if that is where audio is being directed to.

Sorry, forget to mention. I was speaking about motherboard SC. The funny thing is - is working now O_o
I don’t know why it was not working and why i starts to work :frowning:

But yep, my Creative Sound Blaster Z aren’t working.
Everything seems to be normal, expect, that there is no sound on speakers :frowning:
On boot i’ve following message: " 12.276415] ca0132 DOWNLOAD FAILED!!! DSP IS NOT RUNNING."
But after reconfigure sound via YaST i have: “ca0132 DOWNLOAD OK :slight_smile: DSP IS RUNNING.”

But still no sound.

I’ve checked ON that places u’ve mentioned, but still no result :frowning:
Pulse monitors shows activity on card when i trying to play something through it, but no sound :frowning:

P.S. Using alsa 1.0.27 (don’t look at alsa info)

ok, so your mother board sound is now working.

Does it matter if mother board sound is working ? Are you trying to get 2 audio devices working ?

I know how to do this with pulse, but without pulse you likely need to reassign the card# to ensure the device you want to use is card-0. And if this is the creative device, you may need to unmute the mixer settings that I pointed out are muted.

In addition, simply use pulse audio. I provided guidance on multiple sound devices here: https://forums.opensuse.org/blogs/oldcpu/pulseaudio-basics-opensuse-pavucontrol-96/

I know about card-0 (for creative to became a default device) and thanks for the guides :slight_smile:

As i mentioned in my previous post, i’ve unmuted that mixer settings:
https://dl.dropboxusercontent.com/u/10738458/снимок1.png

Sorry for Russian language on screenshot… But as u can see, sound goes to the right card, the problem is that there is no sound on speakers :frowning:

Based on the information provided, assuming no custom .asound.rc file, IMHO there will not be any sound if your systems has it identified as a card other than card-0. Clearly from the diagnostic script you provided that is the case, where it is not card-0. It is card-2. Why should sound work in this case ? Are you still using pulse and have it properly configured with pulse audio per the blog guidance ?

and even if it was card-0, (where the script clearly indicates it is not card-0), I’m not familiar with mixer settings for that card, but you did not address my question about these settings.


**Simple mixer control 'HP/Speaker',0**
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback **[off]**
**Simple mixer control 'HP/Speaker Auto Detect',0**
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback **[off]**

Is it appropriate for those to be OFF ? That suggests a muting.

Why not? I’ve set pulse to use card-2
https://dl.dropboxusercontent.com/u/10738458/img1.png - here u can see that playback goes throw card-2 (HDA Creative)
It really doesn’t matter if i’ll set this card to be 0.

I didn’t thought that my English is so bad, that i failed 2 times to say that i’ve turned them on :frowning:
Here is a new alsa info http://www.alsa-project.org/db/?f=69a19d92469fbf6bef855c084327d94fec78ff49

It was not clear to me from your posts that you still had pulse audio installed. Your first post suggested it had been removed ( ?? not clear ?? ) , and then added back ??? ( not clear ) … and that sound worked for neither. At that stage I see the thread as ambiguous as to whether you had pulse functioning again, and ambiguous if and when you kept the restored pulse audio (and if when restoring pulse audio previous you did so properly -noting I can’t help wrt guidance on how to restore pulse after it has been removed).

wrt the screen dump of pavucontrol, that’s good, but note that is only about 1/3 of what needs to be done. When playing back an application that uses pulse audio, you need to (1) ensure application has pulse audio selected and NOT alsa selected in the applications audio configuration (under its settings or options menu), and (2) ensure that the pavucontrol ‘playback’ tab has the appropriate sound device selected for the application being played.

I see from the script now that they are ON.

You could also do a test to determine IF you audio works without pulse (while still keeping pulse enabled). You can do so if you have a .wav file that you know to be a good .wav file. Say it is called goodsound.wav (an arbitrary selected file name by me).

With that in mind, I note this from the diagnostic script:


APLAY

**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Creative [HDA Creative], device 0: CA0132 Analog [CA0132 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 2: Creative [HDA Creative], device 1: CA0132 Digital [CA0132 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

where from the above I note that hw:0,0 and hw:0,1 are your motherboard audio devices. And I note hw:2,0 and hw:2,1 are your creative audio devices.

Test the following commands from a konsole/terminal (bash shell) and see which, if any, give sound (using your goodsound.wav file) :

Motherboard (card-1):


aplay -d hw:0,0 goodsound.wav


aplay -d hw:0,1 goodsound.wav

creative device (card-2):


aplay -d hw:2,0 goodsound.wav


aplay -d hw:2,1 goodsound.wav

which of those, if any, yield good sound ?

Pay attention to any error messages you may (or may not) get.

None of the suggestions on this thread or any other work for me. I am running Tumbleweed 4/21/15 with kernel 3.19.4-1-desktop.

  1. Sounds works fine on openSUSE 13.2 (at least before any updates after installation)

  2. Most importantly - sound works on the Tumbleweed 4/21/15 RESCUE disk - although there is no Yast Sound modue!

This is most frustrating I’ve ever encountered in openSUSE. Somebody just complained on the openSUSE form a day or two ago. He said it did not happen until a zypper dup on 13.2.

Please help me resolve this - I’m tempted to try Fedora but I sure would never if this problem (acftually a software bug for sure) was resolved.

Thank you.

There was a recent update to pulse audio that broke sound for selected users. You could try rolling back pulse audio to the earlier version.

@ martyfelker -Apparently the fix has been released so you should check again for a very recent update and apply it and you should have your PC sound functioning again. If not post here and we will help you sort this.