Got an ad-hoc connection, no pings(Host Unreachable)

Hi everyone, need a wlan-jedi-warrior here.

I got a Netgear WG511v2 wifi card adapter. Firmware was successfully installed over the ndiswrapper. ‘iwlist scan’ command do found available networks.
So, I’ve configured a connection for wlan0 via ‘Network Settings’ at YaST, this went fine too.
But then I’ve got a problem: other PC do connect to configured wlan, but there’s nothing I can do in a network, even ping says ‘Destination Host Unreachable’.

here’s some output that might be useful:

n22-56-39:~ # iwconfig 
lo        no wireless extensions.

eth0      no wireless extensions.

pan0      no wireless extensions.

wlan0     IEEE 802.11b  ESSID:"set"  Nickname:"n22-56-39"
          Mode:Ad-Hoc  Frequency:2.412 GHz  Cell: 7A:51:55:0E:69:EB   
          Bit Rate=1 Mb/s   Sensitivity=-200 dBm  
          RTS thr=2346 B   Fragment thr=2346 B   
          Encryption key:XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX   Security mode:open
          Power Management:off
          Link Quality:85/100  Signal level:-41 dBm  Noise level:-96 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:193325   Missed beacon:0


n22-56-39:~ # ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:1B:2F:C1:E0:51  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::21b:2fff:fec1:e051/64 Scope:Link
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:130 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:18821 (18.3 Kb)
          Interrupt:21 Memory:40010000-40020000

The scary thing is that ‘RX bytes’ are 0 (same on the second PC, MacBook).
Suse’s IP is and macbook’s is
I’ve tried to get my Internet connection shared with mac via wifi, but stuck here. Also, wlan is in ‘Internal Zone’ in Firewall settings, but as far as I know it’s not critical for pings.

So, where the problem could be?

> So, where the problem could be?

Are you really using ndiswrapper for this device? Mine works with the rtl8187
driver, and does not need firmware!

I have never tried ad-hoc with this device, only managed mode.

Try “managed” mode instead of “adhoc” mode. It should work.

‘Managed’ doesn’t work. Or maybe a miss something. There’s two PCs, no access point, so managed is not a right way.
Anyway, I tried both ‘Master’ and ‘Managed’ modes, none of them works, actually I wasn’t able to even connect two PCs. With Ad-hoc mode PCs do connect, they’re in the same subnet, but they’re not able to exchange any data.
I think succesfull connection means that everything OK with hardware, cuz they able to find each other, exchange WEP-keys and establish connection, so the problem must be somwhere higher than ‘firmware-level’.
Any ideas?

Couldn’t edit, so doublepost, pardon.

So, it works!
I’ve tried ad-hoc mode with no security and key things (‘open’), and everything works brilliant!
So is it some kind of bug and I should post description of this problem and my hardware-list to somewhere, or I’m just too retarted to configure secure work of two wifi-cards? :slight_smile:

If you look at past posts, you will see a number of entries concerning the
breakage of encryption since the security hole was fixed in dbus. You probably
are a victim of that problem.