Google repositories are not automatically configured

I’ve installed Google Chrome and Google Earth after a recent migration from Leap 42.1 to Tumbleweed, and I was expecting from the installation to also configure the Google repos (at least it was the behavior on Leap and on other distros that I’ve used).

But this wasn’t the case; the programs were installed and worked fine, but no repos were added.

Is it an issue with my current system or is it just how it is supposed to work (i.e. something has changed since the last time I had to install them)?

That may depend on how you installed them. Thus a precise description of how you did it is important.

I’ve tried with

cd /path/to/downloaded/package.rpm
sudo zypper in package.rpm

and (from Dolphin) with right clicking on the rpm, Open with > Install/Remove Software (that opens Yast).

Well, when you never used a repository in your whole installation process, how could the system (zypper) then add a repository to your repository list?

They add them via a post install action in the rpm.

@OP, yes I see it’s not added, now I would argue that’s a good thing because I think it’s invasive to add a repository, an at job and a cron job (/etc/cron.daily/google-earth) which I always delete all three. I don’t believe packages updates should occur without some user interaction.

I would suggest a manual download and update, or add the repo manually. I just tested on Leap and it does add them all…


I would say not even user interaction, but system administrator action.

The above reminds me of things I often hear from Windows users.

Honestly I don’t know all the technicalities, but on my previous systems the installation of Google software always added their respective repos.

I agree that software updates should occur when the user wants to perform them, but without a configured repository the whole process is much less streamlined; I’m not interested in cron jobs or other things, but a repo would be handy, and since I can’t find how to configure it manually (on Google sites is only stated that the packages will install them themselves) I’m left with a problem to solve.

Is there some place where I can find the URLs of Google repos?

At least for Chrome,
I posted fairly recently how to install the Google repository for Chrome but Chrome would not install on TW at that time (don’t know if that problem has since been fixed)

Don’t know about Google Earth… I haven’t installed that in TW…

openSUSE does not automatically add Google repos because their apps generally contain proprietary code and SUSE/openSUSE has an extremely strict policy not to distribute anything that contains proprietary code. Other distros don’t usually have as strict a policy. Chrome is such an app, so you won’t find it in OSS or official documentation but you will find Chromium which is fully open source and publicly licensed.


Based on the output on a Leap system;

zypper lr -d 2
Refreshing service 'spacewalk'.

Alias          : google-earth                                      
Name           : google-earth                                      
URI            :
Enabled        : Yes                                               
GPG Check      : ( p) Yes                                          
Priority       : 99                                                
Auto-refresh   : On                                                
Keep Packages  : Off                                               
Type           : rpm-md                                            
GPG Key URI    :                                                   
Path Prefix    :                                                   
Parent Service :                                                   
Keywords       :                                                   
Repo Info Path : /etc/zypp/repos.d/google-earth.repo               
MD Cache Path  : /var/cache/zypp/raw/google-earth   

If you use the following all should be good;

zypper ar -g -f -n "google-earth" google-earth

Thank you.

These two URLs worked for me


Thanks for the repo details.