Google Earth won;t start

OpenSuse 12.1 and the 64 bit version of Google Earth.
Installed with no problems but clicking the icon just shows the bouncing ball until it times out.
Run from a terminal window at least give this message “./googleearth-bin: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory”
libGL.so.1 IS in the /usr/lib64 directory. I assume a simple symlink wil solve it but does any one know the directory to put it in?

Haven’t installed it myself on 12.1 yet, but Google Earth - openSUSE even though the link is old, I think you need to install Mesa-32bit

Thanks, that worked. It put a libGL.so.1 in the /usr/lib directory in case anyone is interested, (at least I assume it’s the same file).
Downloaded the RPM from Google, wonder why it didn’t complain about the dependency?
Well one problem solved with 12.1, only 12 more (so far) to go.

First googlearth complains of unable to find libGL.so.1

Thus, I copied libGL.so.1 from /usr/bin64 to /usr/bin
still google earth complains of error

error while loading shared libraries: libGL.so.1: wrong ELF class: ELFCLASS64

Now I have to boot to Win 7 just to use Google Earth. :frowning:

GE is a 32bit application
You need Mesa-32bit
use
zypper in Mesa-32bit
to install it

On Tue, 17 Jan 2012 06:16:02 +0000, gnulab wrote:

> Thus, I copied libGL.so.1 from /usr/bin64 to /usr/bin still google earth
> complains of error

You can’t copy a 64-bit library to a 32-bit directory and expect it to
work.

Install the 32-bit libraries and it should be fine.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C