Google Earth Install

Hi, everyone, I’m having a problem with installing software. Using YAST and the repositories is simple. Google Earth isn’t in a repository (hint, hint). I found an instruction page at:

Source: Google Earth - openSUSE
Address : <>

Save file GoogleEarthLinux.bin to disk,

  • Install by executing the command (you do not need to be root):

sh ./GoogleEarthLinux.bin

This seems simple, unfortunately after downloading, when I execute the command in user and superuser terminals I get the message: “no such file or directory”. Using zypper install starts a download, of dependencies I guess, then it quits with “nothing to do” without installing Google Earth.

I’ve opened Dolphin to the downloaded file and dragged and dropped it into the terminal. This adds the directory path to the front of the file name, but SUSE and zypper are still unable to locate it and give me the same message. I’ve tried this with the last 2 versions of Google Earth.

What am I missing? Do I have a directorialy challenged version of openSUSE? lol!

I’m using openSUSE 11.1 with KDE4.3.1. The one-click install works great.

Have you checked if the installer is executable? Anyway, since you’re installing from a terminal try this:

chmod u+x /path/to/file/GoogleEarthLinux.bin

before trying again with the sh command. Zypper can’t do anything with that file btw so it’s not surprising those commands do nothing.

I used zypper install GoogleEarthLinux.bin and zypper install /path/to/file/GoogleEarthLinux.bin.

The files are the ones for the last 2 versions of GoogleEarth for linux listed on the website. I assumed they’re executable. How do I tell?

I’ll try chmod u+x /path/to/file/GoogleEarthLinux.bin when I get back into SUSE. I hopes that works.

Which won’t work. Zypper only works with rpm-files, and not .bin files.

In Dolphin, right-click on the file and select properties. In the new window, check the permissions tab. There’s a checkbox called “is executable”. If it’s empty, it won’t be possible to run the installer, script-file, or anything else.

And after that, stay in the same shell and do:


That is, no zypper before.

I just installed Google Earth yesterday. I didn’t bother trying to find it in a repository, I went straight to Google Earth and downloaded the .bin. I made the downloaded file executable (chmod u+x name-of-file.bin) and ran it with ./name-of-file.bin

It did its own stuff for a few seconds and then up popped the window asking for installation locations. Pretty easy stuff, really. :slight_smile:

When I run chmod u+x GoogleEarthLinux.bin I get no a such file or directory message. I get that message with every command I’ve tried. I guess I’m missing something.

It’s not in the repositories. Using YAST is simple. I’ve transferred Firefox and Thunderbird profiles from XP with little trouble, but this seems to require assumed knowledge I don’t have and haven’t discovered in the forums or docs.

These forums have some funky login, thread behaviour. I accessed this thread from the closed tab list and after writing a message it wouldn’t post because I wasn’t logged in, then I couldn’t login. Clicking the login link just duplicated the forum tab I was on. Closing and restarting Firefox fixed it and I was able to login and post this.

I wanted to say thanks to SauronXXX. I checked the permissions tab and the “is executable box” was checked, but greyed out. The owner, group and other lines were blank and also greyed out. It said it used advanced permissions.

I redownloaded and replaced the file. The new one did not have the permissions entries greyed out. I checked the “is executable” box then ran “chmod u+x /path/to/file/GoogleEarthLinux.bin” followed by “/path/to/file/GoogleEarthLinux.bin”. Google Earth installed and works great.

Thanks again,