Google earth does not load

I have GE installed on a 64bit 11.1 system, and when i try to launch GE, I get the following error message, and GE hangs on the splash screen:

ERROR: object ‘/usr/lib64/libv4l/’ from /etc/ cannot be preloaded: ignored.

I understand it has something to do with the linker trying to load a 64bit module, but even installing the 32bit version of V4L2 did not help …

perhaps I should also mention that I have an ATI card, radeon x1300, with the fglrx driver …

I have the same issue and have found no resolution as of yet. I’m using an Nvidia 9600GT with 180.44 driver.

I updated my v4l-32bit and updated my libxcb-32bit to the latest versions from the packman repo and the Xorg repo. This seems to have resolved the issue.

I’ve also turned off desktop effects temporarily, but I don’t think that actually has anything to do with it.

thanks! I added the xorg repo (packman was already in the sources) and ge loaded, if slowly - had to deactivate composition, though, since the ATI driver cannot cope with boht, and ge’s 3d rendition flickers horribly if composite is on

thanks again!