Google Earth 7

I am trying to run Google Earth 7, but it failed to run. Done with all mesa 32bit lib installed, but still no go. Currently I am on 12.3, the machine details as per my siggy below.

linux-wg3z:/home/yazid/Downloads # google-earth./googleearth-bin: error while loading shared libraries: libfontconfig.so.1: cannot open shared object file: No such file or directory



The same however run nicely on openSUSE 12.2. Am I missing something here?

Thank you.

I’m running Google Earth 7 on openSUSE 12.3 64bit with no issues.
How did you install it, through rpm or zypper ?

Using zypper would have resolved dependencies.
I downloaded the file as ‘google-earth-stable_current_x86_64.rpm’ and installed as follows :

zypper in google-earth-stable_current_x86_64.rpm

Try to install the package fontconfig-32bit

Now am able to get it working, too many 32bit lib need to install such as mesa 32bit, fontconfig-32bit, libSM6-32bit, libXext6-32bit, libXrender1-32bit, libx11-6-32bit and some others which I can’t remember.

Thanks to all for replying :slight_smile:

The only problem left now is panoramio layer, I am getting white screen every time I click to any thumbnail images on it. Do your guys have the same problem as mine. Tried the old tutorial here https://en.opensuse.org/Google_Earth by mv the qt.conf into qt.conf.dist but I am still getting the white screen.

Any helps appreciated, thanks again.

The only reason why i don’t install Google Earth:'(

I have exactly the same error as the OP (error while loading shared libraries: libfontconfig.so.1).

I originally installed it using rpm and then uninstalled it and used zypper instead and still get the same problem starting.
The output when finishing the install gives the same warning using either rpm or zypper:

Installing: google-earth-stable-7.0.3.8542-0 ..................................................................[done]
Additional rpm output:
warning:  commands will be executed using  /bin/sh                                                                                                                                      
job 2 at 2013-03-31  13:52                                                                                                                                                                                                                    

The suggestion to install fontconfig-32bit wants to install 67 other 32bit pkgs to resolve dependencies. That includes such things as Samba, mozilla-nss, & systemd-32bit.

What I would like to know is what impact installing all those other 32 bit pkgs on my v12.2 x64 KDE system will have, if any. I don’t want to drag down a fairly stable system to occasionally use google earth.

Thanks, Jon

No problem at all. You even have the option to install the 32bit-runtime-pattern, which installs a load of 32bit libs on your system, to make it easier to run 32bit, or semi-64-bit applications. For some programs you have no other option.

Knurpth:

Thanks for the pattern info. It cut down on all the dependency stuff that it wanted to install for other installed x64 pkgs. I still had to install libXrender and libSM. After that google-earth got further along while starting. Now I get a crash report rather than just an error for missing lib’s.

Rgds, Jon

In reply to my prior query about google-earth I found the following info posted at Google Product Forums.
Hopefully this will help someone else who has GE crash problems.

For opensuse 12.2 64-bit, I had to rename these files, added "backup" in front of the name

/etc/fonts/conf.d/11-suse-hinting.conf
/etc/fonts/conf.d/65-fonts-persian.conf

This solution resolved my crash problem and allows GE to start.

Can anyone tell me why I need the 2 files listed above? What are they for?

Thanks, Jon

Those are configuration files where you edit font related settings
First one is used for correcting

antialiasing ~ noun very rare

  1. (computer graphics) a technique that is used to smooth jagged distortions in curves and diagonal lines so they appear smoother

The second one is required probably to see stuff from “middle east”.

That sounds like it should be no problem for me then.
I figured the Persian would be no problem. I have not idea if removing the conf for the antialiasing will cause me a future problem or not.

Thanks, Jon

6520302 wrote:

>
> In reply to my prior query about google-earth I found the following info
> posted at Google Product Forums.
> Hopefully this will help someone else who has GE crash problems.
>
>
> Code:
> --------------------
> For opensuse 12.2 64-bit, I had to rename these files, added “backup”
> in front of the name
>
> /etc/fonts/conf.d/11-suse-hinting.conf
> /etc/fonts/conf.d/65-fonts-persian.conf
> --------------------
>
>
> This solution resolved my crash problem and allows GE to start.
>
> Can anyone tell me why I need the 2 files listed above? What are they
> for?
>
> Thanks, Jon
>
>
Strange: I have both those files and the 64-bit version of Google Earth
runs fine, after installing all those missing -32-bit libs of course.

Do you guys have problem with panoramio thumbnail viewer? I am getting white screen when I want to view any of images on it :frowning:

powerw00t wrote:

>
> Do you guys have problem with panoramio thumbnail viewer? I am getting
> white screen when I want to view any of images on it :frowning:
>
>
Panoramio and street view work nomally.

Using intel i915 graphics driver.

Hi All

Neither googleearth (v6) or google-earth (v7) seem to work: I get the spash picture


mortenb@mortenb:~> google-earth
Fontconfig warning: "/etc/fonts/conf.d/56-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
*** Error in `./googleearth-bin': free(): invalid next size (fast): 0x08b0fb48 ***
*** Error in `./googleearth-bin': malloc(): memory corruption (fast): 0x08b110e8 ***

mortenb@mortenb:~> /sbin/lspci | grep -i nvidia
01:00.0 VGA compatible controller: NVIDIA Corporation GT215 [GeForce GT 240] (rev a2)

mortenb@mortenb:~> lsmod | grep -i nvidia
nvidia 11317332 31
mortenb@mortenb:~> rpm -qa | grep nvidia
nvidia-gfxG02-kmp-desktop-304.88_k3.7.10_1.1-24.1.x86_64
x11-video-nvidiaG02-304.88-25.1.x86_64
nvidia-settings-270.41.06-1.15.x86_64
nvidia-gfxG03-kmp-desktop-310.44_k3.7.10_1.1-11.1.x86_64
nvidia-computeG02-304.88-25.1.x86_64
x11-video-nvidiaG03-310.44-11.1.x86_64
nvidia-computeG03-310.44-11.1.x86_64

Any idea, worked as a charm on 11.4 on the same hardware.
I’ve installed any 32bit library software mentioned here and ny other beileved to be related.

Thanks

MortenB, Oslo, Norway

Not sure if your google-earth problem is caused by this, but you have installed both G02 and G03 versions of the nvidia driver.
This will cause problems sooner or later!
So please remove all of them and then install either G02 or G03.

And please first of all remove nvidia-settings-270.41.06! This is an ancient version that doesn’t work with your driver anymore!
A working nvidia-settings is included in the nvidia driver package anyway.

Oh and google-earth 6 is working fine here, haven’t tried v7.

google earth works fine as root. But not as any other user.
Even if they are member of the video group.

Try to rename the directory ~/.googleearth

Still having problem with panoramio image preview, in KDE as well in Gnome 3.8.3 :frowning:

https://lh3.googleusercontent.com/-x8uWQix3OaE/UcZZC3ciWwI/AAAAAAAAEp4/huQLt-bovF8/w1304-h815-no/Screenshot+from+2013-06-23+10%3A00%3A17.png