Google Earth 7 crashes

I had problems with my GE 6.2 installation and updated to 7.0 . However this version chrashes on startup, see crashlog below. System: opensuse 12.2 on 64 bit Quadcore with nvidia gc and driver.
Any ideas on this topic ? Is there a stable versio for google earth on 64 bit suse ?


ajor Version 7
Minor Version 0
Build Number 0002
Build Date Dec 13 2012
Build Time 17:54:43
OS Type 3
OS Major Version 3
OS Minor Version 4
OS Build Version 11
OS Patch Version 16
Crash Signal 11
Crash Time 1356527552
Up Time 0,005025

Stacktrace from glibc:

I am unable to get Google Earth version 7 to run. None of the online fixes I found does anything to make version 7 run. Its very likely some mixed Libraries are to blame and until Google Earth 7 is in one of the openSUSE repositories, it may never work properly. My suggestion is to drop back to version 6 for now you can find in this repository “” as it does work just fine and it is called Google-earth-stable I think.

Thank You,


There was a whole slew of problems with G7 I had them too go here:

Take a look especially at the link in post #14 that was what solved it for me. GE7 now works great for me!

Thanks, 6.0 is now running. I’ll also try the remove-font-trick later.

Since version 6 of Google Earth works & I have not seen a universal fix for GE7 in openSUSE, there is no good reason to go to version 7 right now in my opinion. I feel you are wasting time for no good reason trying to get GE7 to work and perhaps (a few fixes are) putting something else in jeopardy with the fixes I have seen. First, none of the GE7 fixes I have tried (including as suggested in this thread), cause GE7 to work for me. Unless there is fantastic feature in GE7, besides wasting time and effort, who cares if you keep using the older version of GE? So indeed I may wait until GE8 comes out before I try anything else and perhaps you should consider doing the same. As always, the choice is up to you.

Thank You,

In my case installing Mesa-32bit did the trick.

And I also have mesa 32 bit installed. I have tried this on three different machines. I always use nVIDIA video, but having or not having the nVIDIA proprietary video driver loaded has made no difference for me. It may be specific to hardware or libraries or what ever you may use, but unlike GE6 which needed only a few fixes, there is no universal fix for GE7 that I have seen so far.

Thank You,