google desktop gadgets

Just wondering if anyone has had any success at compiling google-gadgets-for-linux-0.9.3 on an OpenSuSe system yet?
I have tried and I hardly know where to begin with all the errors reported after ./configure
Perhaps I’ll start at the 1st ones…

checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking how to run the C++ preprocessor... g++ -E
checking for g77... no
checking for xlf... no
checking for f77... no
checking for frt... no
checking for pgf77... no
checking for cf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for xlf90... no
checking for f90... no
checking for pgf90... no
checking for pghpf... no
checking for epcf90... no
checking for gfortran... no
checking for g95... no
checking for xlf95... no
checking for f95... no
checking for fort... no
checking for ifort... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for ftn... no
checking whether we are using the GNU Fortran 77 compiler... no
checking whether  accepts -g... no
checking the maximum length of command line arguments... 1572864
checking command to parse /usr/bin/nm -B output from gcc object... ok

There are a lot more later on, but perhaps they are because of this lot above.
Obviously I’m missing something, but where do I start? I have got the basic development packages installed and have compiled other software, such as vmware workstation and f-prot antivirus.
I am running OpenSuSe 11 64 bit.
Thanks for any help, regards Peter.

You appear to be missing a Fortran compiler - most of the messages are just checking to see which one you have. Search in YaST for either “gfortran” or “gcc-fortran” (I can’t remember its exact name) and install it - this should help.

it installed pretty easily for me a few days ago.

did you make sure you had all the dependencies listed under “pre-requirements” on this page:

HowToBuild - google-gadgets-for-linux - Google Code

after that i just went to the directory where i had the “google-gadgets-for-linux-0.9.3.tar.gz” and extracted it into same directory. then just the basic “./configure”, “make” and as root “make install”, compiled it without a hitch for me.

Yeah, I just had to install a few more development packages and it installed fine. Pretty neat stuff.
Thanks for the help.
Regards Peter.

You can get then with one-click here


Thanks for that. :)I’ll try it out on my next install.
Regards Peter.

I couldn’t get the one click install to work. When I tried to launch Google Widgets I get “Program can’t start because it failed to load the following module(s): smjs-script-runtime”

How do I resolve this. I am running openSUSE 11 KDE 3.5.9 and used the qt install.

There are packeges of new version Google Gadgets in hfiguiere repo and everything works great :smiley:
Thank’s to the packeges author :slight_smile:

I’m wondering why there are no rpm packages for openSUSE in official Google repo, since in the very same repo I can find i.e. Fedora packages with Gadgets. Any ideas?

why there are no rpm packages for openSUSE in official Google repo

it still beta relese…

Because google is using ubuntu :slight_smile: