Google Chromium

Hi guys, when Chromium starts, the first tab pops-up a warning:

You are using an unsupported command-line flag: --no-sandbox. Stability and security will suffer.

None of my launchers has this flag set. Googling about for this warning gives some answers, most of them re. MSWin 7, including removing the flag from the command line of the launcher (none is set) and adjusting various options in about:flags but none seem to be relevant.

However if I go to about: in the address box, the following result shows up:

|Chromium|24.0.1290.0 (Developer Build 160607)|
|---|---|
|OS|Linux|
|WebKit|537.13 (Unknown URL@0)|
|JavaScript|V8 3.14.1.2|
|Flash|11.2 r202|
|User Agent|Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.13 (KHTML, like Gecko) Chrome/24.0.1290.0 Safari/537.13 SUSE/24.0.1290.0|
|Command Line|/usr/lib64/chromium/chromium --no-sandbox --password-store=kwallet --flag-switches-begin --enable-autologin --show-autofill-type-predictions --flag-switches-end|
|Executable Path|/usr/lib64/chromium/chromium|
|Profile Path|/home/stephen/.config/chromium/Default|



/usr/lib64/chromium/chromium

is a ‘shared library’ and I don’t know to to change things within it.

In that directory /usr/lib64/chromium are two scripts, chromium-generic and chromium-kde, both of which mention this switch:

SUSE Paste

SUSE Paste

I don’t know if these are relevant or even being used.

The above scripts have a line pointing to:

APPNAME=chromium
LIBDIR=/usr/lib64/chromium
GDB=/usr/bin/gdb
CHROME_SANDBOX=/usr/lib/chrome_sandbox

The is no such file/dir in /usr/lib/chrome_sandbox

And further down:

if ! -u $CHROME_SANDBOX ] ; then
SANDBOX="–no-sandbox"
fi

Should I create an empty file there? Or a directory?

Or should I boycott Google altogether as despite their ‘don’t be evil’ motto they are are evading corporation tax in the UK… :wink:

This may be a specific problem with the 64 bit version; there was a similar problem with the 32 bit version several versions ago. A quick check with my (otherwise identical) 32 bit version shows that /usr/lib/chrome_sandbox does exist and I have the same scripts in /usr/lib/chromium/ but I do not get the same message.

The file “/usr/lib/chrome_sandbox” is part of the package “chromium-suid-helper”. That should have been installed. If it is not there, then install it.

Thanks guys, but:

sudo zypper in chromium-suid-helper
root's password:
Loading repository data...
Reading installed packages...
'chromium-suid-helper' is already installed.
No update candidate for 'chromium-suid-helper-24.0.1290.0-1.19.1.x86_64'. The highest available version is already installed.
Resolving package dependencies...


Nothing to do.



Try the version(s) from the network:chromium repo, they work perfectly.

Thanks Knurpht, I did that… (I think!) but it is still the same…
Here is about:version

|Chromium|25.0.1352.0 (Developer Build 171464)|
|---|---|
|OS|Linux|
|WebKit|537.21 (Unknown URL@0)|
|JavaScript|V8 3.15.8|
|Flash|11.2 r202|
|User Agent|Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.21 (KHTML, like Gecko) Chrome/25.0.1352.0 Safari/537.21 SUSE/25.0.1352.0|
|Command Line|/usr/lib64/chromium/chromium --no-sandbox --password-store=kwallet --flag-switches-begin --enable-autologin --show-autofill-type-predictions --flag-switches-end|
|Executable Path|/usr/lib64/chromium/chromium|
|Profile Path|/home/stephen/.config/chromium/Default|



Maybe uninstall it, and then install it again. Somehow that file (it seems to be the only file in “chromium-suid-helper”) has gone missing.

I thought I had solved this, but it is back. I did a complete uninstall, and re-installed from the chromium repo. Any ideas anyone? Or other forums/resources?

openSUSE version?

Uninstalling/Reinstalling is (in by far most of the times) not the way to go.

Please post output of

zypper lr -d

and

rpm -qa | grep chromium

Hi Knurpht, I was following the advice offered by nrickert in the post above yours.
Here is zypper lr -d :~> zypper lr -d # | Alias | Name - Pastebin.com](http://pastebin.com/jsJf1RuS)

And :

~> rpm -qa |grep chromiumchromium-desktop-kde-26.0.1403.0-348.1.x86_64
chromium-ffmpeg-26.0.1393.0-100.1.x86_64
chromium-suid-helper-26.0.1403.0-348.1.x86_64
chromium-26.0.1403.0-348.1.x86_64



12.2 KDE 4.9.5 r4 BTW

where did you get your version of chromium?
Latest available from openSUSE update repo is 26.0.1383

Getting it from elsewhere could be half your problem.

oh, I see you got it from the openSUSE chromium repo.
Versions here as I understand it are for early testing before being sent out to the update repo - so you are bound to run into problems with versions from this repo from time to time.

This is what I have installed, note the difference:

rpm -qa | grep chromi**chromium-ffmpegsumo-26.0.1403.0-348.2.x86_64**
chromium-desktop-kde-26.0.1403.0-348.2.x86_64
chromium-suid-helper-26.0.1403.0-348.2.x86_64
chromium-26.0.1403.0-348.2.x86_64



Interesting…I doubt that this can be the cause of the problems, unless you know better, but still it is an obvious mis-match. I have therefore got rid of:

chromium-ffmpeg-26.0.1393.0-100.1.x86_64

(yast told me that they conflicted) and replaced it with

chromium-ffmpegsumo-26.0.1403.0-348.1.x86_64

Could you please, Knurpht (and anyone else, just to compare) show me your

#> ls -l /usr/lib/chrome_sandbox

Hi folks, I just had a long old chat with someone on IRC #chromium-support, He obviously knew his stuff. It seems that there is a bug/problem in the opensuse packaging of chromium. He asked me to raise a bug, but I know that I am not sufficiently expert to give the correct info, so I would be grateful for some guidance.

Here is the conversation:

SUSE Paste

As requested:


laptop:~> ls -l /usr/lib/chrome_sandbox 
-rwsr-xr-x 1 root root 18856  6 feb 10:17 /usr/lib/chrome_sandbox

What’s weird, is that I installed Chromium on approx 20 machines (customer demand), running 12.1 and 12.2, both 32bit and 64bit, without any issues. They started using Chromium as a default (with gmail, drive configured), this afternoon they gave it a definite “go” after testing for 2 weeks.

Have you tried removing all Chromium packages, then reinstall the base Chromium package and let it pull in the deps?

Yes, I did. My advisor from IRC thinks it is the -rwsr-xr-x which is causing the problem. Mine resets itself to -rwxr-xr-x

Yesterday’s update via autoupdate brought the no–sandbox flag back.

Any known plans to fix this? Until this chromium is not an option to use.

ok steh ja im thread ein simples:

su
chmod 4755 /usr/lib/chrome_sandbox

reicht aus um das Problem zu lösen, als Mausschubser hat mich das finden des Kommandos auch wieder 40 min gekostet.