Google Chrome Stable failed to load

I just accepted an update on Google Chrome Stable and when I tried to open it, got an error message that said something about couldn’t run init launcher. Sorry I didn’t jot it down, it was either KVM or KDE. Tried rebooting to fix it but that locked up the machine and I had to power down to reboot. Got the same error message after reboot. I used yast to download the software and it opened. However, I got a message box that said keyring failed to load, enter password. I have never seen that before and have no idea what the keyring is or what the password is for it.

Can you enlighten me?

try running from command line to see errors

Don’t run Chrome (too shiny :slight_smile:

But check the file and see if the name has changed also

This thread helped me partially solve it.
https://forums.opensuse.org/showthread.php/519726-KDEInit-could-not-launch

If you are using KDE then edit applications and go to google chrome. in the advanced tab put in the working path… /opt/google/chrome/
I also changed the command on the main tab to google-chrome %U
Save your changes. It should work after that. However, I still can’t get it to launch from an icon on the panel.

I had the same problem but a delete/reinstall fixed it.

I’ve had this issue on both my laptop and desktop. Both instances uninstalling and then re-installing chrome fixed my issue. I had wondered if other people have had this issue as well and sure enough.

Yup. Seems there’s something wrong in the spec file of the rpm, but that’s Google’s, we cannot change it.

Thanks for the help!

FYI -
More than likely from your description the problem was how and where Chrome stores passwords… eg in a KDE system Chrome will offer to save your passwords in Kwallet. I imagine if Chrome were installed in a non-KDE system, then another local cert storage will be recommended, and that’s likely the gpg reference.

As you’ve probably discovered,
Uninstalling and re-installing might implement the correct procedure(Upgrade seems to be faulty) to connect to whatever storage you’re using.

TSU