Google Chrome RPM Beta: failed to install

subprocess failed. Error: RPM failed: warning: /tmp/google-chrome-beta_current_i386.rpm: Header V3 DSA signature: NOKEY, key ID 7fac5991 error: Failed dependencies:
lsb>=3.2 is needed by google-chrome-beta-

That is the error message I get when I try to install Google Chrome’s RPM for Fedora/openSUSE off the official website (Google Chrome - Get a fast new browser. For PC, Mac, and Linux)

Any suggestions? I’m happy with Firefox for now, but the fact that it is not skinning near the address bar nor the actual menus themselves (when you click on them) makes it ugly. Plus, I’m up for a change - I’ve been with Firefox for quite a while now.


Just open the YaST installation module and search for “lsb”. I’m not sure in which repo I had it, but I think you’ll find it pretty easy… Select it (mine was >4 I think) and install it. Now you can install Chrome with no problems. Keep in mind that afterwards, you have to direct Google Chrome at the plug-ins folder in order to use Flash I think…I haven’t done that myself,but I read it in a thread somewhere :wink:

…Actually, I just searched on openSUSE’s “One-Click” Software installer (online) and installed Chromium. I guess it’s basically the same thing as Chrome, just open-source. I guess I’ll stick with Chromium until Chrome for Linux is out of Beta.
I just would like to know why Chromium says it can’t detect if it’s the default browser (which it isn’t) and that it can’t change it anyways.


You can install chrome by downloading it instead of running software installer on it (which runs rpm). Once you have the file, do zypper in google-chrome-… which will pull in lsb if you don’t already have it. Or install lsb first.

Chromium != Chrome. Chromium is the community compiled version, although I suppose the differences will disappear in time since Google released the official version. It’s all open source, only that Google didn’t release the source for the Chrome Linux port till recently.

I installed chrome exactly the same way, the only difference is that I used Yast instead of Zypper :)…

And yes, the other difference I have created a local directory on my system where I download rpm’s first. I have included this directory as a repo in Yast. So what I do is, download rpm’s to this local directory, open Yast, select the rpm I have to install… Then Yast solves all the dependency issues and the install goes fine …

Interesting, I’ll have to try that.

Or download the missing dependen(cy)/(cies) myself via Yast and try Google’s RPM again.

However, I’m not sure why I should use Chrome if Chromium works perfectly fine. Someone tell me the difference between the two, other than Chromium is community-compiled? I figure that Google themselves will take a bit to get everything down right themselves…

Okay, openSUSE Forums really needs to allow you to edit your posts!

Well, I installed lsb (turns out the tools were installed but not the core itself. :rolleyes: )

Google Chrome works fine.

Chromium uninstalled.

Thanks! (Now, let’s see if you can “Mark Thread as Solved”!)

EDIT: Okay, whoever’s in charge of openSUSE forums needs to check out Ubuntu Forums. They just recently added “Mark Thread As Solved” under the “Thread Tools”, and they also have a few features that the SUSE forums don’t.

Somebody should look into that.

On Fri, 18 Dec 2009 22:16:02 +0000, SPARTAN-118 wrote:

> Okay, openSUSE Forums -really- needs to allow you to edit your posts!

Editing is generally enabled for a short period; every 10 minutes,
messages are passed through a gateway to the NNTP server, and at that
point posts are not able to be edited.

“Mark as solved” has also come up repeatedly over in the forum
suggestions group - you can read the discussions that have already
occurred and information about how one can mark a thread as solved.


Jim Henderson
openSUSE Forums Moderator

I’m running the Beta on OpenSuse 11.2 64 bit. I have to say it’s great and noticeably fast. Bit of manual tweaking for plug ins, but they work fine (64 bit ones too!)
Just drop the Flash and Java plugins into the Chrome Plugin folder.
Now then, I’m confused. What is the difference between Google Chrome and Chromium. I know that Chromium is Open Source, but is there any actual difference in them? Does being Open Source affect plugins etc?
Oh, but I might also add that sections of the OPenSuse web pages do not display as expected when using Chrome, there seems to be a large gap between the headers and content on some page s(noteably the software pages)
Regards and best wishes for the silly season, Peter.

Strange, neither Chromium nor Chrome affect the pages for me…

And I never had to install any Flash or Java plugins. Perhaps your problems are related to the fact that you’re using 64-bit? I’ve never used anything other than 32-bit Operating Systems, so I have absolutely no clue what the difference is (besides the obvious, like speed).

There really is no difference between the open source Chromium and the official Chrome. Besides the obvious difference between the fact that you’re not using the ‘official’ release, and the fact that community-managed applications might not keep up with the official updates, I really don’t see any diff.

Now, would somebody tell me why I can’t set Chrome as my default browser? I did it in the “Default Applications” of “Configure Desktop”, and told Chrome to set itself as default, but I never get a “Chrome is the default browser” confirmation in the Options menu.

Yeah Spartan. the default flash plugin was pointing was pointing to /usr/lib/browser-plugins
I just sim linked my 64 bit javaplug in to the google chrome plugins folder an d just dropped the 64 bit flash plug in to the same folder.

Oh, alright.

But, seriously, I know that this is not related to the original thread topic, but how come Chrome won’t set as default?

Tbh I’m not sure, it seem’s to not be able to check if it is default either (even though on my system it’s the only browser apart from Chromium).

As for the differences in the two of them, there arn’t really any apart from the obvious. Chromium will get feature’s and advance’s faster than Chrome but as far as it goes both will always be hand in hand with eachother.

Chromium’s bookmark sync has worked for age’s, Chrome only has it in the latest “unstable” which is 4.0.266 while Chromium is 4.0.273.

Chrome would seem the more “stable” thing to go for. Chromium if you want to try features that may or may not turn up in chrome.

Also the webpage layout thing I get as well on both Chrome and Chromium but it only seem’s to affect the Package and Download pages the rest are fine :S.

Well, I absolutely have to keep Firefox on my PC, as some pages only work for IE, Firefox, and on the rare occasion, Safari.

So, wait, you uninstalled Konqueror? I thought that you were supposed to keep that on your computer?

You can remove pretty much anything you want to (Within reason) :stuck_out_tongue:

I do the install’s without even Konq in place, Konq used to be required as it was also the file manager, but since Dolphin i’ts sorta took a back seat and imo has become somewhat useless.

Hmm, maybe I should uninstall Konqueror, since I’ve never used it, anyways.

BTW, pmccrackan, what’d you do to get the Flash and Java working, again? I thought they were working in mine, but I just went onto Youtube and it said I need the latest Flash player (which I’m pretty sure I’ve already DL’d).

Also, my apologies, but at first all pages displayed correctly - then I went and searched for some software that wasn’t on the repositories over at, and everything was way at the bottom, like described.

There is an “IE Tab” plug in for both Firefox and chrome. It works as if you are opening the page in IE. You will not miss IE ever. I have not, till now :slight_smile:

Got Flash working, found a support how-to on how to do it.

Basically, for anybody who doesn’t have Flash working properly (or at all) in Chrome/Chromium, first thing you have to do is open a Dolphin window via root:

name@linux: sudo dolphin

Then navigate to /opt/google/chrome and create a new folder called “Plugins”.

Next, download the latest Adobe Flash Player beta: Adobe - Adobe Flash Player
and put it in the “Plugins” folder. (The file is the .so file, not the script. When I ran the script, it did nothing.)

Restart or open Google Chrome/Chromium, and all Flash content should work properly.

Note that all these steps can also be done in the Terminal (Konsole), but I prefer using the GUI to command line.