Google Chrome (KDE) Quick Launcher issue

openSUSE 13.1 kde

Google chrome > show launcher when not running enabled
When clicking the launcher I see:

There is no application installed that can open files of the type shared library (application/x-sharedlib).
Do you want to try to install one?

Works from the menu fine etc…
Chromium is fine in every way

So I was having the same problem and found a workable solution.

Make sure all previous launchers for chrome are removed

  1. Open chrome
  2. Right click Icon only task manager and select Icon-Only Task Manager Settings
  3. Select Launcher Matching Rules from the left pane
  4. Click Add button on the right
  5. On new dialog box click Detect Window Properties
  6. Mouse pointer should turn to target, click on chrome window, this should auto fill some stuff
  7. In same dialog next to launcher section click the file folder icon, Select launcher application window should open
  8. Internet -> Web Browser -> Google Chrome
  9. Click Ok -> Ok -> Apply
  10. Now When you select show launcher when not running it should add the proper icon

If you right click on the launcher while chrom is running you will see a chrome item in the drop down menu, not sure how to remove this but it is only a minor annoyance. If you figure out how to remove this let me know. If you have trouble following I can probably post screenshots, let me know.

I seem to remember seeing that, the first time that I started chromium. Or maybe it was the first time that I started opera.

I ignored it (I probably said “no” to a prompt). And everything is working fine.

No, didn’t happen with Chromium or any other app.
And it keeps happening

Still trying to figure out the earlier comment… by @miked63017

What are you stuck on?

I couldn’t see a path to follow what you list in 1-10

I have some screenshots but just realized they need to be hosted, I cannot directly insert them here. I forgot to mention that I copied the google-chrome.desktop file from /opt/google/chrome/ to my desktop and initially launched it with that prior to step 1. If you pm me with your email I can send you the pics, unless you can recomend an image host to use for these boards, I got about 12 screenshots.

Here we are imagbam:

Remove existing launchers for chrome, if you have any](

copy desktop file](

The rest should be in order from the steps in my previous post, and files are named accordingly on imagebam, hopefully the links work](](](](](](](](](

Here is the weird thing that I cannot get rid of, but does not affect anything](

But those are icons not quick launchers

I was under the impression that add launcher added quick launchers. What is a quick launcher then?

Launch chrome from the normal menu > Right click the task manager box running in the panel SUSE Paste
Close chrome and launch from the new quick launch icon

This is exactly the same thing I have setup, my main task manager is at the top of my screen. My directions setup a quick launcher using the method in your paste however there are a few steps to do first for it to work properly.

I’m currently using a side panel with autohide on for quick easy access to apps
SUSE Paste

Man…you just tldr all over the place :). My point is that this yields a quick launcher not an icon.

Just signed up, I’m using arch linux and this solved my problem, TXHXXX rotfl!

No problem, glad to hear it :slight_smile:

Thank you, miked63017, your solution worked for me.

I also could not find the Icon-Only item but there is a simpler workaround for this. Just open a terminal and run google-chrome then select ‘Show a launcher when not running’ for this one.
The problem with the initial one is that it does not call google-chrome simply.