Google Chrome crashes about 85% of the time when do search in address bar!

I’m seeing an issue where if I do a search in google chrome in the address bar (i.e. type something with spaces in it like “chrome linux crash”) then at least 85% of the time, Chrome will just quit. When I start it up again, the tabs are gone and there’s something that says “Google Chrome didn’t shut down correctly. To reopen the pages you had open, click Restore”.

Does anyone know what might cause this and how to diagnose it?

On 04/23/2013 06:06 PM, 6tr6tr wrote:
> how to diagnose it?

what version are you using…is there a more stable version
available in the repo? have you tried a more stable version?

did you install it with YaST?

have you tried disabling all add-ons?

what operating system and version are you using?

have you tried chromium…does it do the same?

if you start it in a terminal, and leave that terminal open, does it
throw error messages or comments, or what?

if you look in the logs do you find any info about what happened?


dd

Version 26.0.1410.43 but this has been happening for a while, even in past versions.

no. I downloaded it from Google.com, but it does do updates via zypper.

I don’t have any addons other than Flash which I disabled. Are there addons built in?

openSUSE 12.1.

Where do i get chromium?

I’ll try this.

Where are the logs for chrome?

Thanks!

OK, I ran it from the command line and discovered it DOES seem to have to do with Flash. With Flash disabled, it kept running (with errors, but probably benign - see below). With Flash enabled, it crashed with the error:

**Floating point exception**

Benign errors that did not cause crash:

ERROR:object_proxy.cc(624)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
ERROR:object_proxy.cc(624)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
ERROR:object_proxy.cc(529)] Failed to call method: org.chromium.Mtpd.EnumerateStorages: object_path= /org/chromium/Mtpd: org.freedesktop.DBus.Error.ServiceUnknown: The name org.chromium.Mtpd was not provided by any .service files
ERROR:object_proxy.cc(529)] Failed to call method: org.kde.KWallet.isEnabled: object_path= /modules/kwalletd: org.freedesktop.DBus.Error.ServiceUnknown: The name org.kde.kwalletd was not provided by any .service files
ERROR:native_backend_kwallet_x.cc(227)] Error contacting kwalletd (isEnabled)
ERROR:object_proxy.cc(529)] Failed to call method: org.kde.KWallet.isEnabled: object_path= /modules/kwalletd: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
ERROR:native_backend_kwallet_x.cc(227)] Error contacting kwalletd (isEnabled)
ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()


is there a way to fix this?

su -
 zypper in chromium

On 04/23/2013 07:36 PM, 6tr6tr wrote:
> is there a way to fix this?

are you using the latest flash? if not, you should.

try:
-go to any site with flash
-right click in the spot where flash runs
-select “Settings”
-on the Display tab, make sure the “Enable Hardware Acceleration” is
NOT checked
-click “Close”

does that help?? if not try


dd
http://tinyurl.com/DD-Caveat

It was checked. I unchecked it and will see if that stops the crashes. Thanks!

Google Chrome comes with pepper flash built in.
You could try disabling that and use the flash version from the non-oss repo.
I don’t recall how to do it but it should be pretty easy to find with google.

Alternatively, chromium is in the oss repo and does not use pepper flash - so you may have better luck with that.

6,
I at one time used to use Google’s Chrome, but I gave it up for the problems you’re having now. So My recommendation
1)remove the Google Chrome. after that
2)click to view the hidden files in your /home look for & then trash a folder called “.pki”
3)then look in your /home for a “.config” folder open it up then find & trash the chrome folder
4) do as vanhazdan said in post 6
5)then if you have the Packman repos enabled zypper in the chromium-pepper-flash it seems chromium works better with it from Packman
Now in my experience there’s no thing you can do in GC that you can’t also do in chromium. Plus with chromium IIRC you’re not being tracked like you’d be in GC.

Ok, I think there are some malfunctioning or unsupported add-ons (also called as extensions or plug-ins). Such add-ons are usually responsible for constant Chrome crashes. Here’s how to deal with these types of add-ons:

  1. Open Chrome.
  2. Click Wrench, select Tools | Extensions.
  3. Disable one by one individual add-ons.
  4. Re-start the browser.

More info in this video:
https://www.youtube.com/watch?v=Q1lGFxNLZC4