Google and libkdeinit5

I installed Leap 42.3 last weekend for a friend and all was working fine; but this weekend, when he tries to access Google, he gets the message:

Couldnot launch google[LEFT]Couldnot open library libkdeinit5 google[/LEFT]Cannotload library(libkdeinit5google cannot open shared object file: nosuch file or directory)

I see there is a thread about this in Tumbleweed a year ago and one about this in Leap 42.1 two years ago. But neither seem to be relevant as KDE:Frameworks5 is very much part of Leap 42.3.

Any suggestions?

Well, it would be interesting to know what exactly is being tried here and how.
E.g. what does “he tries to access Google” mean…

More details, please.

He is using Chromium to access gmail which he does by going to

And what is he doing exactly?

He enters into the browser address line and the error appears?
I somehow doubt that.

The error message sounds more like he is trying to run “google”. But the application is called “chromium”, not “google”.

No, he is a bit more savvy than that. He is entering in the chromium location bar in the same way as he enters in it to get to gmx.

I’m afraid I can’t help then.
I don’t use Chromium and don’t even have it installed.

Still, this error message doesn’t seem to come from Chromium but rather from KDE.
As I said, you should provide more details.

Maybe it’s caused by some Chromium extension/plugin that’s installed? Or some setting in Chromium maybe.

Thanks. He is off on holiday; so it will be another fortnight before I can see exactly what the problem is. Will report back if it is something significant.

I know what the immediate problem was; I had set up a Desktop icon pointing to chromium but, for simplicity, had given it the name Google because he used it for Google searches and Gmail. However, the command entry in properties had changed from chromium to Google after the install. Because chromium is not part of the standard install, I wonder whether KDE was trying to be helpful when it could not find chromium when my friend clicked on it before I had installed chromium.

I doubt he would have changed the entry himself as he normally asks for advice about configuration issues. All the other icons, for things which were part of the standard install, worked fine.

Well, I’m not aware of a KDE feature to automatically adjust the command entry (Exec line) of desktop “links”. If the command cannot be run, only an error message will be displayed, like it was the case now.

But a wrong entry explains the error message of course.

Btw, you never mentioned that the error message appears when the user clicks on a shortcut on the desktop.
That’s what I meant with more details, that are necessary to get an idea what might be wrong.

Unfortunately, I didn’t have those details and I couldn’t think of a suitable question to elicit more details.