good news ... bad news

The Good news…
I have been running openSuSE 41.2 and putting off installing 42.2. I have been having trouble with my Bluetooth since the UpDates on 41.2 between Jan 5th and March 1st. I tried removing the UpDates but was NOT successful. Screwed up my system but then recovered and UpDated to the latest 41.2.

I then decided to go forward instead of backward and just do an “UpDate/UpGrade” to 42.2. I had/have VMware 12 with Windows 7 and Windows 10 as guests. A few others like Quanta Plus, qps, Bluegriffon and Bluefish. After the UpGrade they all worked fine except Quanta Plus. I had to re-install it. Both of my Windows workstations worked fine.

I used “zypper dup” with a downloaded Leap 42.2 DVD as the only selected repo.

The Bad news…
My Bluetooth still doesn’t work. It works in Windows 10 … which I can dual boot to. However, got some Windows UpDates while I was over in Windows and it messed up my boot order. Had to do an F10 at bootup and go into the BIOS and move “opensuse-secureboot” from the bottom to the top. This is a UEFI system.

I just find it interesting that I can get my Bluetooth to work in Windows but not in Leap 41 or 42… on the same system. However it did work in Linux(Leap 41.2) in January of 2017… this year. It broke with Updates between Jan 5th and March 1st. I didn’t, and don’t, use the Bluetooth everyday… just got it for Christmas… so I am not sure which UpDates “broke” it.

My System in an HP 700-530qe…i7-4790… Windows 10 UEFI… yes I am proud of it. Wish I would have had something like this back when I was working…:expressionless:

The reason(s) I posted this is to show that “UpDating” to 42.2 is not as bad as some have experienced. Just wanted to let the Dev’s know that they are doing good work. But there are still some minor problems… like the Bluetooth … which seems to be a problem in most of the Linuxes out there. In my Web Searches I find a lot of people on various Linux systems having troubles with Bluetooth devices… and Broadcom.

Thanks to all for your efforts,

I see no question for technical help in this thread. Thus it will be moved to General Chitchat and is CLOSED for the moment.

When there is some question for help hidden deep in this post, please start a new thread in the most appropriate sub-form with a title that will be attractive to those that might be able to help in having at least keywords about the problem.

Moved from Install/Boot/Login and open for consumption.

I’ve been inclined to not trust updates and prefer clean installs making sure that they don’t over write things I want to keep. I put those in a partition and look at what the installer chooses to do with partitioning. On leap 42.2 I didn’t have to do anything with that it just formatted and installed where it needed to and left the rest alone. I had backed up via a usb dock anyway just in case.

My only problems were that when I imported the partitioning from my old system it it looked ok but install didn’t locate /home correctly as I map that to a separate disk, a raid in my case. The other was a sound problem that is probably just down to the fact that I use an optical output from the sound card. I’m pretty sure that is down to my card working to the Phillip’s original standard and that differs from toslink/ice958.

As far as bluetooth goes I don’t use it but wonder if you are using KDE for the desktop. If start-sytem-info centre show the device you might find that start-settings-system settings - bluetooth might configure it for you. If info centre isn’t showing there is a chance that it’s not being picked up so probably best to ask in the network section on here. All sorts can cause problems. I for instance have a graphics tablet plugged in. The kernal recognises it but can’t do anything with it as I haven’t installed a driver for it yet. The driver is maintained by a gent in Germany so I can’t expect the disto to include it even if Hanvon tablets are very good and 1/2 the price of one of the famous makes with the same facilities that the distro probably does support.

I usually stay away from kde’s general network settings - if things are working but when they haven’t been in the past those have helped too but I’d only use them if I am desperate.

Leap 42.2? - I was running 12.3 before and both work more or less perfectly really and I suspect that leap has a lower cpu and memory load.


Ignoring the “General Chit-Chat”:
Please post the following (you may have to install the package “rfkill”):

  • “# rfkill list”
  • “# lsmod | grep -i ‘blue’”
  • “# systemctl status bluetooth.service”
  • “# systemctl list-unit-files | grep -i blue”
  • “# systemctl list-unit-files | grep -i kill”
  • “# systemctl status systemd-rfkill.service systemd-rfkill.socket”

Also, if you’re running KDE (and sometimes when you’re bot), AFAIK Bluedevil is still the bluetooth stack that is installed and aside from basic device detection should be the main way to manage and troubleshoot bluetoth devices.

Here is the Archwiki link, ignore the installation sections which are Arch Linux specific, but everything else should be relevant


broadcom can have issues with open source OS’s. It barely works at all on OpenBSD.