GNUCash and Perl Finance::Quotes

One of the reason I’ve updated to 11.1 (from 11.0) was to have a more recent version of GNUCash and the Perl module Finance::Quotes.

But now, I can no more retrieve share quotes from within GNUCash as it complains that Finance::Quotes is not properly installed.
I tried to re-install the Perl-Finance-Quotes package, but it didn’t help.

Any hint on how to solve this ?

Additional info:

# gnc-fq-dump
Can't locate HTML/ in @INC (@INC contains: /usr/lib/perl5/5.10.0/i586-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/lib/perl5/site_perl/5.10.0/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl .) at /usr/lib/perl5/vendor_perl/5.10.0/Finance/Quote/ line 41.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.10.0/Finance/Quote/ line 41.
Compilation failed in require at (eval 44) line 1.
BEGIN failed--compilation aborted at (eval 44) line 1.
 at /usr/bin/gnc-fq-dump line 147
Can't locate object method "methods" via package "Finance::Quote::VWD" at /usr/lib/perl5/vendor_perl/5.10.0/Finance/ line 112.

Even more, found this on Google :
Nabble - MacPorts - Tickets - [MacPorts] #18997: p5-finance-quote requires p5-html-tree to work properly, but doesn’t list it in deps

(Still hunting…)

Even more, found this on Google :
p5-finance-quote requires p5-html-tree to work properly, but doesn’t list it in deps

INDEED, installing the Perl-HTML-Tree package solved the problem.

So there is a dependency problem with the package : perl-Finance-Quote 1.15-1.12

You seem to be having a fair few problems unless I’m mistaken you’ve done an upgrade from <11.1 to 11.1

With the problems you’re encountering I’m beginning to wonder whether that actually went that smoothly.

Yes, I’ve updated from 11.0 to 11.1 yesterday.
The update went right, but I’m discovering a few (so far, minor) problems.

If you’re in doubt, think that is safer to update between minor updates than major ones (like waiting for a major release like 12.0, for which I would advice to UPGRADE).
I’m overall pleased with 11.1 (again, so far :wink: ).

Between cyberspace and me posting you seemed to of solved this. Just seemed at the time you where adding more and more.

Might want to take this up with the pkg maintainer if this is related to a missing dep. Googling it seems this is a common thing with this combination across a variety of distro’s(That is missing deps)

As for between minor and major think that is getting less and less relevant than it used to be. I also believe there should be a dist update from running distro, coming soon(Sure I caught something recently).

I’ve just posted a bug report about this :