GNU Backgammon worked in LEAP 42.3 but doesn't work in LEAP 15

A couple of days ago, I updated from Leap 42.3 to Leap 15.0 (using KDE in both 42.3 and 15). The documentation was great and the update went smoothly.

Today I tried to play GNUBackgammon on 15 and it does not show any screen output. I ran it from the KDE menu. and also from the command line. Granted that this is not the biggest deal in the world, but I would like to waste some time playing again.

The “top” command shows that gunbg is running with 100% CPU usage. Running $gnubg 2>&1 gives no output. I uninstalled it and re-installed it, but that didn’t change the behavior.

Does anyone have suggestions on getting this game running?

Many thanks,

(This message was also posted in the install/upgrade section. I got no replies after a few days. Sorry, but I could find no way to just move it here after I got no replies there.)

I too had no luck with gnubg-1.04.001-lp150.1.18.x86_64. My strace -f gnubgtold me that gnubg ran into a futex which either should return immediately or wait, but instead was using 100% of one of my CPU cores. Weird.

After searching those experimental openSUSE repositories, *( as an RPM package … then, as root:

  • rpm -e --nodeps gnubg

  • **rpm -i --nodeps **

Back as unprivileged user again, trying to start gnubg, it said it was missing version 8 of the GNU readline library…

~/Desktop ▶ **gnubg -w**
gnubg: error while loading shared libraries: cannot open shared object file: No such file or directory

Now I could download the readline-8 source, compile it and install it, but then I thought: Is v8 really that different from v7?
I decided to cheat. As root, I did the following:

  • cd /lib64/

  • **ln -s **

  • **ln -s **

That’s right, I’m making GNU Backgammon think I got libreadline version 8 installed, but I dont, and gnubg seems fine with it. Quick and dirty, there you go. lol!*

Thank you. I’ll give this a try…*

Many thanks. Works perfectly. Brilliant solution!!!