I’ve been developing arm code using windows for some time now. I’ve been slowly migrating to SUSE and have come to the point where I’d like to develop code using my SUSE machine. I have read many posts, google, on setting up the cross compile toolchain but can’t seem to get this to work to be able to compile my code. I looked in the standard repos and found the arm binutils but can’t find the gcc-arm-elf package needed for compiling. I even tried compiling from source the gcc and binutil sources found on gnu arm without success. I’m too inexperienced with linux to know why it didn’t work but I followed the instructions from a site that described the compiling steps. I’ll include the link if anyone would like to review. When I tried to “make” the various packages it looked like something was happening but the steps never created a /usr/local/arm7 directory that was supposed to house the necessary tools.

Anyhow, anyone that has experience with this that might be able to help, I’d appreciate it.

Thanks, Dan