Gnome3 won't start after 13.1->Tumbleweed update

Hello openSUSE users!

I have used openSUSE for a couple of years and I was really exited when I was told there is a rolling release version of the OS. So I gave it a try on a brand new installation (x86_64), but I wasn’t successful and ended up with a broken Gnome3 and a messed up system…

What I have done is to install 13.1 64bits Gnome version on my system (brand new install), update packages with yast online update, then follow the guidelines to get Tumbleweed. Neither proprietary drivers, nor virtual machine, nor spicy stuff. When I rebooted, what I only got was a “Oops, something went wrong” Gnome3 message and inability to connect to my session with GUI…

Analyzing the /var/log/messages told me that symbols were undefined in .so files:

/usr/bin/gnome-shell: symbol lookup error: /usr/lib64/gnome-shell/ undefined symbol: g_app_info_monitor_get

As suggested in this thread (May 2014), I have checked the version of libgtk and I was surprised it was still 3.10, as well as some other gtk3 packages. The fact is when crawling the repository, libgtk 3.12 is available, but yast couldn’t see it (repository priority?). So I tried to install the 3.12 gtk packages with zypper and rebooted. But the problem wasn’t solved at all and I was still struggled with a broken Gnome3. When I analyzed the /var/log/messages again, the same g_app_info_monitor_get was missing.

Eventually, when I checked with yast, everything involving gtk3 was at 3.12.* version.

As suggested in the opensuse-gnome mailing list (May 2014), I have tried to use xdm instead of gdm, but it didn’t help.

I don’t know then where is the problem. So I have reinstalled a 13.1 version and run with it, but I want to try out Tumbleweed (with Gnome)! What could you advice me? Wait a bit longer?

Thanks for your answers!

That’s a problem with branding packages that comes and goes in Tumbleweed. Some GTK related branding packages have a higher version in the Current-Update repo than in Tumbleweed, so those are installed preventing the upgrade of some other packages (they require the lower versioned GTK/GIO packages in 13.1), resulting in an incompatible mix.

My suggestion would be to either run “sudo zypper dup --from Tumbleweed”, or give the Tumbleweed repo a higher priority (i.e. lower priority number) than the Update repo and run “sudo zypper dup” (you do know that you have to use “zypper dup” to update on Tumbleweed, right? :wink: )

Another way to prevent the problem is to install the branding-upstream packages instead of branding-openSUSE.
I’m not sure which packages exactly would that be, gio-branding-xxx and gtk3-branding-xxx at least.

Thank you, wolfi323, changing repo priority did the trick!

After distro update, I ran updates and was forced to switch gio-branding and gtk3-branding from openSUSE to upstream, as you said.

But changing the repo priorities should prevent you from having to switch to the upstream branding.
If you change to the upstream branding there’s no need to change repo priorities in the first place.

What do you mean with “ran updates”, btw?
You should only use “zypper dup” to update your Tumbleweed system, that’s the only supported way.
Better disable your desktop’s update notifier, or only use it to inform you of updates, and actually run “zypper dup” when there are some.