gnome-system-monitor VERY slow to startup

hello people

i have a system monitor applet in one of my panels to monitor CPU load.

When you click this applet, it opens up gnome-system-monitor. I’ve had
this since 10.2.

But after i upgraded to 11.1, when i click the applet, it takes about 1
minute to openup gnome-system-monitor! i’m not joking, you even forget
you clicked there when it finally opens.

I’ve seen this happen on 2 new installs (not upgrade, but new
installation), but on both of these i upgraded my desktop definitions
from GNOME included in 10.3. Everything else is working fine.

Does anyone have the same bug or is it just me? Any clues on how to
solve it?

thanks in advance


careta’s Profile:
View this thread:


i have exactly the same problem…
Just to know i have another issue. The gnome-main-menu have it’s right
part very wide… do you have the same ?



csgib’s Profile:
View this thread:

I guess it’s a common problem caused by that new «Hardware» page in
gnome-system-monitor. The bad thing is that there is no way to disable
it (or I didn’t found it) so it may be inspecting the hardware every
time it starts. I have no idea why there is need to have such
information in resource monitor if I can’t even do anything with it.
It’s just a tree-list of hardware no more.

Guess it should be moved to any other app or removed at all, it’s
useless and annoying. Also, I recommend htop for resource checking, it’s
lightweight and console while g-s-m usually consumes processor time more
than any other process, even X, lol.


eurekafag’s Profile:
View this thread:

You could add your comments or vote for this bug :


Have a lot of fun! WJM

Magic31’s Profile:
View this thread:

Oh, it really starts fast when launched from terminal. Then I’m wrong
about hardware tab, thanks.


eurekafag’s Profile:
View this thread: