GNOME-Shell Refuses to Work after FULL REINSTALL, What's Going On?!

Hello there.

I have recently been pulling my hair out with Gnome-Shell. I had Gnome3 including the shell up and running as soon as it was ready in the stable repos. However it recently refused to work after the update to 3.0.1 hit the stable repository.

Today I did a complete reinstall of OpenSUSE 11.4 from the gnome desktop CD, NVIDIA drivers are correctly installed and working. Gnome3 has been installed via the one-click method on top of this FRESH install.

Yet still my gnome-shell freezes after login, I am running in fallback mode now. Really cannot see what can have gone wrong this time, nothing out of the ordinary has been knowingly installed at all. I’d really love to get my desktop up and running to how it used to be.

Any help will be greatly appreciated.

Have you set the repository priority to 98 for the GNOME 3.0 Stable repository?

Hi Malcolm

All the repositories are set to 99, should the gnome 3 stable be set to 98?

Yes it should :wink:
openSUSE:GNOME 3.0 - openSUSE

Set the priority and do a zypper dup. I would suggest doing it from the console as well (runlevel 3)

Hi Malcolm,

Thanks for the help. This is what I have done.

Set the Gnome 3 repo to 98, logged out to cli, performed a zypper dup as advised.
Reinstalled gnome-shell.

Reboot and the problem persists, gnome-shell freezes upon login. Any other help you can offer me? Really pulling my hair out with this now. Thanks for the help.

So you ensured all the additional items were installed as per the text install on that link? Are you sure the nvidia driver is running, check with glxinfo command?

It’s up to you to follow the suggestion I posted here: GNOME 3 Fails to Work After Update - HELP Appreciated. But if you want to solve the problem, you should try to find out what’s causing it. Simply reinstalling is just as inefficient as simply starting a new thread about the same problem, it doesn’t usually increase your chances of success.

Thanks, yes the log info would be good… use SUSE Paste for any log information :slight_smile:

Hi Again all,

This is what I have done to try and fix this increasingly ridiculous problem:

  1. Remove the Gnome 3 “stable” repo, logout to runlevel 3, perform zypper dup. Gnome 2 working fine.
  2. Add the gnome 3 repo again, set priority to 98, runlevel 3 and run another zypper dup, ensuring that both the adwaita theme and gnome-shell are installed as per the instructions from official documentation.

Once again the problem persists. After login gnome-shell freezes and refuses to respond. I will try and obtain a log, but in the meantime if anyone has any other ideas it’d be appreciated as quite frankly this is ridiculous. I’d expect software from Redmond to bork and fail after install, but not one from OpenSUSE.

First post. Hi all! :slight_smile:

I’m no expert here, but after a clean install, the fact that you are still experiencing this issue leads me to think that perhaps it could be your graphics hardware. Are you using any other OS’s, and are they performing OK? I only ask because some time ago I had a similar problem with my Ubuntu installation, where it would glitch out and then hang at login. Upon trying my other installed OS’s, I discovered that they were all experiencing issues similar, and that the fan on the graphics card had stopped, causing overheating and hence the problems. I bought a new fan system, and it’s been fine since. It’s the first thing that popped into mind when reading your post Dawth. It might not be a software problem.

I installed Opensuse 11.4 with Gnome 3 a while ago and had the gnome-extensions issue that’s been mentioned before (the Oops! message). But on a fresh install later (I’d been messing with Ubuntu 11.04) the OS has been fantastic, and the extensions are no longer causing me any problems. Could be worth some consideration.

Hi Kinzie,

You’re right, it could be my graphics hardware indeed, however I have had gnome3 fully working beforehand. My graphics card appears to be working fine as I am able to watch HD video and play Minecraft in fallback mode fine.

I have however just now tried installing Linux Mint 11 and trying the PPA for Gnome 3 and am now experiencing the same issue, perhaps it is my gpu, I wouldn’t be surprised if ANOTHER nvidia card has given up the ghost on me.

But it seems strange if 3d acceleration is working fine and yet it can’t run a desktop shell.

Hmm that is odd. Do you have a temperature monitor installed to keep an eye, or can you otherwise see the card and see the fan is working OK?

Another option is if you use a separate /Home partition, and a config file somewhere from your old install is causing you problems on your new one.

Hi there

I regularly keep an eye on the cards temp, it normally stays arounds 65. Not exactly cold I know hut it would work in fallback mode.

I took the card out and ran it with my Gma 950. Gnome 3 including the shell worked beautifully on the mint install. So now I have reinstalled opensuse and am very happy with gnome 3 and minecraft working great. Thanks very much kinzie for sharing your solution, has me back up and running.

Thanks everyone for their prompt replies and help, one of the best things about this my favourite distro is the community.

Yep I’m having the same issue. Nvidia driver working fine on Gnome2 and icewm but gnome-shell won’t start after the latest batch of updates

Yo need to run either Gnome 2.x or Gnome 3.x not both…

I’m not sure its even possible to have both installed but yeah… what I meant was I reinstalled Gnome2 and all was good, then installed Gnome3 again and it wasn’t

I wonder if some of the .gnome2, .gconf and .gconfd files are an issue. If you get around to trying it out again, I would look at a fresh install from the liveCD after backing up your home directory so it’s a pure Gnome 3.0 install.