Gnome-shell memory leak?


I have a little question. The same from the title.
To be honest, I asked this question to another forum (a distro who has gnome as it principal DE) and … no answer.

I thought that I am the only one with this problem. But I read this and I realized that I am not the only one:

I have been used Gnome for a long time. Now I use TW + KDE (and I am not turning back). But old habits were hard to take and I have one VM with TW+Gnome.

Are there other people with the same problem? And there is a solution for this memory leak?

Thank you.

Your reference is an interesting and instructive read.

Just shows that writing C code is not that easy in that there are things… even things which are commonly warned about can have aspects that are easily overlooked. So, in this case it’s almost a universally known “feature” that C code is not managed and so things like garbage collection must be the responsibility of every codebase management, never to be overlooked and never to be forgotten. So, everyone seems to have been very careful to make sure that their contribution was always marked for GC as necessary. But, it seems that actually executing the GC was overlooked which would possibly should have been the responsibility of some higher level in the codebase but maybe not assigned or at least reviewed recently.

from the blog description,
All very understandable.
And, as long as the problem is fixed as permanently as possible (not just for this one issue), I don’t see what anyone has to complain about.


Its distro agnostic:

Waiting for gnome 3.28.2 :wink:

.......notably some widely discussed memory leak fixes for GNOME shell.

In need of a reliable hacker who works discreetly and
delivers promptly, he does all kinds of hacking service’s.Phone tap,Change school grades, hack’s cheating spouse’s, recover email & facebook lost password & does all kinds of Credit card Top Up also into Bank transfer. You can contact


Which might take a while before the leap users get it.
My guess is with SP1 at the earliest…

I am not sure that it resolve the problem.
I tried gnome 3.28.2 (with Fedora not openSUSE because in Fedora it appeared faster) and the problem still exist. After 10 h gnome-shell memory was ~ 800 Mb. Even if I close all applications, the memory did not drop at all. For me, the problem is not solved.