GNOME Shell Lost Desktop icons

I have lost some icons from my desktop, they are, firefox, yast, thunderbird, emacs, the space and the names are still there, and when I hover the mouse over the space, it is highlighted as it should be. The application opens and runs as normal when I click on the space where the icon should be. The icons are also missing from the favorites bar on the left side and also from the panel top left when the app is running.

I have tried, rebuilding the icon cache in ‘usr/share/icons/hicolor’, and also all other icon caches for that matter, and no difference. I tried uninstalling and installing the app, no differenence. I tried changing themes and icons from Tweak Tool, no difference. As far as I can see the icons are there in the hicolor directory.

Anyone any ideas, as a last resort can I re-load Gnome 3 without losing all settings and installations, will the Gnome 3 application just check/repair any missing or corrupted files. (ps dont ask if I have a backup, I haven’t.)

THanks all

Do you have gnome-tweak-tool installed? If not install and check the
‘Interface’ options Should be ‘Adwaita’ and gnome for the icon theme.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel
up 1 day 14:29, 4 users, load average: 0.01, 0.05, 0.05
GPU GeForce 8600 GTS Silent - Driver Version: 270.41.06


Yes, already tried that, thanks

Well this is what you get for installing that is nothing better then beta in quality.
I would personally go back to gnome 2 or just use KDE, they will forever work better then the ever pitiful Gnome 3 and its stupidity filled gnome shell.

Wthout getting in to an argument mate, if we all had that attitude we’d still be living in caves, (or shoeboxes)!


Gnome 3 isnt about advancement, its about stripping down something that was for most people very usable and very customizable into a un customizable, and very unusable mess of a UI.
Didnt we learn from what happened with KDE4 when it first came out?
Or Vista?
Newer doesnt mean better.
It took 3 years for KDE4 to reach nearly half the abilities as KDE3, and the stability.
3 years is a long time
Windows Vista came out in 2006, 3 years later windows 7 came out…
See a pattern?
All the errors, the issues of all these things were caused by foolish developers and the rush for the latest and greatest.
It took 3 years for both KDE and Windows to make up for the mistakes they made, if I were the developers I would keep gnome 2 going for another 3 years but they wont because:
A: they are morons
and B: they already killed gnome 2 off forcing the rush to this new and messy release.

So you are at version 3.0.2 of the shell? Force the reinstall of the hicolor-icon-theme and hicolor-icon-theme-branding-openSUSE.

Of course you are entitled to your opinion, and you are obviously very well informed/qualified to give such a strong opinion so early in its release, personally I prefer Gnome 3, but each to there own. My original post was to ask for assistance, not get into a debate over Gnome3, and that is still the case, however it would be interesting to here other opinions.

Oh and by the way, most of those ‘morons’ helped develop gnome 2 in first place.

Yes ver 3.0.2, how do I force the install, I already re-built the hicolor icon-theme-cache.


There is no one twisting your arm to install Gnome 3 :wink: If you want to rant take it to soapbox or the gnome-shell mailing list, Thanks.

Just use;

zypper in -f  hicolor-icon-theme hicolor-icon-theme-branding-openSUSE

There are some macros that the rpms run that hopefully clean it up…

Else does it duplicate if you create a test user and login?


Tried zypper and it reinstalled the directories, but still the same missing icons, not sure how to create a test user.


Use YaST -> Security and Users -> User and Group Management and hit the add button, then once finished, logout and login as that test user.

Hi done that, but when i try to log in get this message:: could not update ICEauthority file /home/test/.ICEauthority

i think i have to change ownership with chown but i can’t find the file!

If it doesn’t exist, login as your normal user and open a terminal;

su -
touch /home/test/.ICEauthority
chmod 600 /home/test/.ICEauthority
chown test:users /home/test/.ICEauthority

Then try logging in again as user test

You might also want to check other file permissions and ownership in the test and your user home directories…

Maybe in you playing around it somehow changed the permissions of some files?

I did that, but i get when I try to create the file with touch, i get the error message ‘no such file or directory’, should I create a directory called ‘test’ first, then the file


Ahh, you didn’t select to create the test users home directory in YaST, login back as your user and use YaST to delete the test user and then re-create, just check the box to create the users home directory…

No, I created it in the terminal with usradd before I read your instruction, in future i will not jump ahead of things and wait for your advice!

I will get back to you


Ahh, you need to add the -d option

useradd -d /home/test -G users -c "Test User" test
passwd test

You can check the other defaults with useradd --show-defaults

Edit: -m creates the home dir as well…