Gnome Shell Extensions Weirdness???

Hi all,

I’ve been a user of Gnome 3 since it was made available. I thoroughly enjoy the use of extensions, I’ve recently upgraded my hard drive and as such have made a fresh install, now setting up my new desktop I notice that whilst trying to use certain extensions, such as weather - from malcolm’s repo, this happens:

Has anyone any ideas why this is happening? It’s quite annoying as I rely on some of the extensions I’m looking to get working properly.

Here is an output of what extensions from the repos I have installed:

S | Name                                  | Summary                                                     | Type   
i | gnome-shell-extension-alt-status-menu | GNOME Shell Extension -- Power Off Item in Status Menu      | package
i | gnome-shell-extension-alternate-tab   | GNOME Shell Extension -- Classic Alt+Tab behavior           | package
i | gnome-shell-extension-drive-menu      | GNOME Shell Extension -- Removable Drive Menu               | package
i | gnome-shell-extension-hotspot-icon    | GNOME Shell Extension -- Displays the distributor logo icon | package
i | gnome-shell-extension-monitor-applet  | GNOME Shell Extension -- System Monitor Applet              | package
i | gnome-shell-extension-noa11y          | GNOME Shell Extension -- Remove a11y from panel             | package
i | gnome-shell-extension-places-menu     | GNOME Shell Extension -- Places Status Indicator            | package
i | gnome-shell-extension-user-theme      | GNOME Shell Extension -- Support for Custom Themes          | package
i | gnome-shell-extension-weather         | GNOME Shell Extension -- Weather Notifications              | package
i | gnome-shell-extension-weather-lang    | Languages for package gnome-shell-extension-weather         | package
i | gnome-shell-extensions                | A collection of extensions for GNOME Shell                  | package
i | gnome-shell-extensions-lang           | Languages for package gnome-shell-extensions                | package
i | gnome-shell-extensions-master         | A collection of extensions for GNOME Shell                  | package
i | gnome-shell-extensions-master-lang    | Languages for package gnome-shell-extensions-master         | package

Any help with this will, as always, be greatly appreciated.

Yours Kindly,


The last 5 on your list can be removed, they are benign containing readme’s and language files…

So it’s still hard to see what the issues is, can edit the screenshot with some pointers? I see you have set them to the right, rather than center.

Also check in lookingglass for errors (press alt+F2 enter lg <press enter>)

Hi Malcolm,

Thanks for taking the time to respond. Basically whenever I enable either the weather extension from your repo or the mediaplayers extension which is the note symbol in the screenshot the icons of those shell extensions become over-sized in comparison to the actual top panel. Perhpas if one could click on this link here - which only takes you to the full view in Picasa, it’s a full HD screenshot - one will see my problem

Thanks for the info on those shell extensions, I’ll go ahead and remove them. I’ve patched gnome-shell in order to obey the themes like normal, so they fit as they normally would when using any theme.



So if you don’t move the extensions position to the right, all is ok? Can you leave the media one disabled (That’s not packaged by me, wasn’t happy with it) and do you see the same effect?


If I revert the changes I have made it is exactly the same as this. Also if I run the shell with the media player (a great extension which strangely works on my netbook) disabled and the weather extension enabled, the result is the same again.

After you made the changes did you restart the shell? I would say it’s
a conflicting name in a stylesheet.css file…

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel
up 3 days 7:45, 3 users, load average: 0.00, 0.05, 0.11
GPU GeForce 8600 GTS Silent - Driver Version: 270.41.06

I, of course, restarted the shell. Even did a log out and then back in to get the full effect :slight_smile:

It really is a strange bug, I don’t get it on my Netbook, also running 11.4 with the same patch applied and weather etc working fine.