gnome-settings-daemon is not started

Hi,

After I login my desktop preferences are not loaded. If I try to change them (Control cneter-> apparence) I get a message that says:

Unable to start the settings manager ‘gnome-settings-daemon’.
Without the GNOME settings manager running, some preferences may not take effect. This could indicate a problem with DBus, or a non-GNOME (e.g. KDE) settings manager may already be active and conflicting with the GNOME settings manager.

The first lines of .xsession-errors show:

/etc/X11/xim: Checking whether an input method should be started.
HOSTNAME: Undefined variable.
XDG_DATA_DIRS: Undefined variable.
/etc/X11/xim: line 82: Terminal: command not found
sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale en_GB.UTF-8 …
There is no default input method for the current locale.
Dummy input method “none” (do not use any fancy input method by default)
Terminal set to VT100.
gnome-session[9277]: WARNING: Could not parse desktop file /net/home/ezq/.config/autostart/qstart.desktop: No such file or directory
gnome-session[9277]: WARNING: could not read /net/home/ezq/.config/autostart/qstart.desktop
gnome-session[9277]: WARNING: Could not parse desktop file /etc/xdg/autostart/ksmolt-autostart.desktop: Invalid key name: X-KDE-autostart-condition$e]
gnome-session[9277]: WARNING: could not read /etc/xdg/autostart/ksmolt-autostart.desktop
GNOME_KEYRING_SOCKET=/tmp/keyring-CfOoY2/socket
SSH_AUTH_SOCK=/tmp/keyring-CfOoY2/socket.ssh
GNOME_KEYRING_PID=9456
gnome-session[9277]: WARNING: Application ‘gnome-settings-daemon.desktop’ failed to register before timeout

As you can see the daemon is not started by timeout.
I do not know where to look for more information…
Do someone know what to do.

Best regards,

Zunbeltz Izaola

Hi. I had this on Debian testing, and the solution was to manually run gnome-settings-daemon from a terminal, then go to System -> Preferences -> Startup applications, and select to ‘remember applications that are currently running’.

Don’t know if it’ll help - but it’s worth a shot.

[You might be able to put an & after ‘gnome-settings-daemon’, so you can shut the terminal without closing it… Can’t remember]

I have a problem.

OS: openSUSE11.2 32-bit
GUI: GNOME

I used FreeNX Server. When I login from my NX Client will install Keyboard (English-Thai) I go to the menu, Control Center> Keyboard.

Error message:
Unable to start the settings manager ‘gnome-settings-daemon’.
Without the GNOME settings manager running, some preferences may not take
effect. This could indicate a problem with DBus, or a non-GNOME (e.g. KDE)
settings manager may already be active and conflicting with the GNOME
settings manager

If users login console it work, No error. He can be configured different.

Bug report - I am not sure
https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/199245

SUSE Enterprise Desktop it worked.

Best regards,
Setup Google XML Sitemap Generator for WordPress

WOW, 1 year ago.

Same problem on SLED11 SP1 (Gnome - gnome-settings-daemon Keyboard Preferences error)

Status: A Waiting from Novell support.

First, you’re reopening an old thread.
Second, this is about SLED, not about openSUSE. SLED has it’s own forums, a link is on the home page of these forums.

Hi
Because it’s reported upstream (Gnome) it will take awhile to filter
down as well. Please keep followups in the SLE forums.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.3 (x86_64) Kernel 2.6.34.7-0.4-default
up 13:09, 2 users, load average: 0.16, 0.12, 0.16
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.12