gnome screenlets and compiz fusion

Hi -

I use 10.3 x86_64 with gnome and compiz-fusion running on the proprietary nvidia driver.

Using screenlets manager I load up several screenlets at startup, but there is some weird interaction with my desktop that is causing them to not display properly. For example, the netmonitor screenlet has numbers that are only partially formed. The wireless screenlet has a strange transparent strip running left to right.

All this is solved by opening screenlets manager after I boot and selecting “Restart All Screenlets”.

I wish that I didn’t have to do this every time. Is there some solution? Maybe to get the screenlets to load up later in the start-up cycle?


  • John

and if u just restart compiz?

Running XGL or AIGLX?

Nvidia. I think that qualifies as neither.

It turns out that clears up the screen as well.

This got me to thinking about how these apps are getting loaded. Unlike many people, I load compiz and emerald via “Control Center” -> Sessions -> “Startup Programs”. There is supposed to be some suse script for loading compiz-fusion automatically, but that never worked for me back when 10.3 was new, so I’ve been doing this ever since.

Screenlets are getting loaded in Startup Programs, also.

If I could somehow manage the sequence of when everything loads, I think I could resolve the issue…

OK. I think this is resolved.

Having gotten to thinking about reordering how applications were being loaded by Startup Programs, I quickly discovered that this could be controlled by settling the “Order” parameter under “Current Session” and then (important!) saving the session by pushing the button on “Session Options”.

This required some trial and error, as my initial inclination was to start Compiz last (well, second to last, before emerald). But it turns out the Compiz doesn’t like that at all. I instead told it to start the screenlets last.

Seems to be working. Thanks for all help.


I am using 10.3 too, with same CPU.
Also I have nVidia video-card and compiz, emerald.

Yesterday I ran my first attempt to test screenlets which I found only from an external (non official) repository.

I have been not able to start screenlets nor screenlets-manager from startup manager.

Neither by trying to start from console, in both cases I noticed some complains with a “glib assertion function”.

Sorry I cannot be more accurate because I am at office now.

Wonder which versions of screenlets you’ve installed along with glib, gtk2 and dbus and from which repo I can download it.


as an alternative you could use gdesklets… they work fine for me. I trying screenlets too but as for me gdesklets more pretty :slight_smile: