Gnome screen blanker

I have a couple of question regarding the screen blanker on Gnome desktop.

I used to use a 1024x768 display with previous openSUSE distribution. With 11.3, I discovered the new “auto-configure” X feature. The default screen mode was 1600x1200, but I changed it to 1280x1024.
My gfx board is a Matrox G400 DH. Hardware acceleration is disable because of a missing (fall back to software rendering).

I find some screen blanker modules are using almost all the CPU cycles. Animations are very slow, and it can take long before a keyboard hit or mouse movement makes to leave the blanker.
So the questions:

  • Is there a way to define another (smaller) screen resolution just for the blanker ?

  • Who should I try to convince to add back in Mesa again ?

  • When the monitor go to sleep (DPMS), the blanker still is running, uselessly consuming CPU times. (I can see that because at the first mouse/kbd event, the monitor wake up and shows the blanker running.) Is there a way to configure the blanker to stop running when the monitor is sleeping ?

  • There are some modules which load images from HD (not the diaporama which load images in ~/images). But the shown image is always the default built-in one. Where is the blanker trying to load images from ? is now back in Mesa for openSUSE 11.3 and up (latest Mesa package from the Factory), enabling 2D/3D acceleration for Matrox G series owners. :slight_smile:

So now, the slow and CPU hungry screen savers are less a problem for me.

Compared to KDE screen savers, the Gnome ones have less configuration options… But yet, even under KDE, I haven’t found an option to disable the screen saver when the monitor is in sleep (DPMS) mode (but maybe KDE is smart enough to do this automatically ??).

Also, I still haven’t found how to replace the 'TV tunning" default image for some of the image-manipulation modules (and no option under Gnome to scpecify a directory). Any idea ?