gnome problems???

A noob here ana course i gots a problem.

installed opensuse (gnome brand) on centrino laptop(3G mem 320meg drive - alongside win7)
worked fine-but the gui faculties appear to be deteriating fast.

yesterday logged in on admin account-- the window title bars and borders vanished and i kept getting repo failed to connect warning ( most irritating) used Yast to disable remove all but essential repos and seemed to cure prob #2 howsoever trying to disable compiz?–seemed flaky at best—those were yestiiday’s problems today when I logged on the admin account things were horrible and now while i can open a terminal window no keystroke activity available–can’t open yast because the admin logon doesn’t recognize keysyrokes. writing this from local user account that does allow terminal use but the win title/borders missing and logging to this forum was a bit flaky although as i’ve typed this no problems except phat fingers?

anybody>:( care to take a shot at this one?

Why login as root into a GUI? On your user account, open the Control
Center and start desktop effects, and disable that way. Else you need
to start Compiz Config Settings manager from the ‘More Applications’ on
the slab menu and scroll through the list and check the box windows

Sounds like your system may have updated the kernel and you need to
re-install the display driver…

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 9 days 13:22, 4 users, load average: 0.10, 0.09, 0.08
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53

willedoit wrote:
> yesterday logged in on admin account

do not do that.

you should never log into KDE/Gnome/XFCE or any other *nix-like
graphical user interface desktop environment as root…

doing so 1) opens you up to several different security problems, 2)
too many too easy ways to damage your system no matter how careful
your actions (example: just browsing in your home directory while
logged into KDE/Gnome/etc as root can lock you out later as yourself
due to permissions damage), 3) and, anyway logging into KDE/etc as
root is never required to do any and all administrative duties…

so, always log in as yourself, and “become root” by using a root
powered application (like YaST, File Manager Superuser Mode) or using
“su -”, sudo, kdesu, or gnomesu in a terminal to launch whatever tool
is needed (like Kwrite to edit a config file)…read more on all that

*now, since you already did that, and apparently trashed your system
already it might be time to decide how far you are into this and if
make sense to do another fresh install…or flail around trying to
repair all the holes in your feet…

oh, and -=welcome=- to our forum, and freedom…part of that freedom
is you have the ability to murder your system at will by “trying”
things, “experimenting”, “playing with”, “fooling around with” and yes
also by using the procedures and techniques used on other systems,
whether those are Mac, Atari, PlayStation, Wii or Microsoft…you
just can’t expect all sytems to do exactly the same things the same
ways, safely…

there are lots and lots of user guides, wikis, how-tos and etc that
are very useful…i’ve listed some of them in a previous posting,


Well it appears that you don’t have root privileges in the gui anyway eh? I was trying to use root (or yast) to work on the compiz?/win titles problem.
Iffen you can’t get to da gui app to setup/turn offen da flaky app your lederhosen yah?


Could ya gimme clue on how to update/remove the display driver?

Hope I didn’t appear too flip but I got the impression that you(the GUI) weren’t the root account and since it’s a fairly new install,I tossed 'er in da bit bucket. still would be curious about disply drivers as I have a system with a video that gives some issues— but then this prolly not the thread fur dat hunh.

Thanks again.

I’m glad to see these linux GUIs finally getting so well polished since I made some serious effort a decade or so ago to set up a linux box.

It’s come a long way from the tty machine and the pc board/chips I first used, so pardon an old f**t for mucking things up. I’ve been flying the Jolly Roger for quite awhile and disliked windoze(as pretty as the graphics are)for all the layers they put twixt me and the hardware.

problem solved/vanished unimportant? Thanks

So you found the compiz configuration stuff and fixed your issue ok?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 (i586) Kernel
up 2:31, 2 users, load average: 0.04, 0.12, 0.09
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

Nah, as I wrote,I was early in the install setup (couple a weeks) so I took your advice pulled off any thing of value put the 11.2 livecd in and started over.

yeah, I’'ll take a shot at figuring out how all those pretty pixels get put on the screen over time as life happens. I got opensuse(kde brand) on another machine and want to see which one I live with as I transition away from windows

willedoit wrote:
> yeah, I’'ll take a shot at figuring out how all those pretty pixels get
> put on the screen over time as life happens.

you might benefit from some of these:

some may be more basic than you need, some more advanced than you can
use…don’t be put off by any “new user” labels…i know you may have
lots’a years knocking around in many other systems…good buddy :wink:


THANKs palldium,

I gotta a chance 2 read the first URL in that first postings list and found is an interesting read- It brought some things into focus on how all those gui layers interact with the underlying OS.

1 question if I may- in trying to get some access to the root level I looked at SUDO- but was unable to add any user/aliases/command etc- natch I’m a little leary of using visudo to edit it(have been researching da subject on line). Does the SUSE distro deactivate it or do i have 2 go at it from other means-- I know I can’t hurt da hardware–but caution is warranted.

i rarely use sudo, have looked at visudo (once, found myself in the
IMPOSSIBLE to use vi and bailed out) so can’t advise…